2

I need to access to '/Users/marienfarge/.config/NuGet' for a problem with virtual studio but i can't open the folder. (I have a red '-' on the folder)

When I tried to open it : 'Impossible to open the folder '.config' because you don't have the necessary authorization to display his content.' (translate form french so it's maybe not exactly this message for english user)

So I tried to modify the access in the info panel and I give the read & write access for everyone but I still can't open the folder.

Someone told me to wrote this in the terminal : ls -leO@d /Users/marienfarge/.config/NuGet

And this is the answer : ls: /Users/marienfarge/.config/NuGet: Permission denied

I'm the only user of the mac and I have the last os version.

ls -leO@d /Users/marienfarge/.config provides the result

drwx---rwx 3 root staff - 96 9 nov 15:47 /Users/marienfarge/.config

2
  • Can you run ls -leO@d /Users/marienfarge/.config? – nohillside Jan 21 at 10:15
  • @nohillside this is the answer : drwx---rwx 3 root staff - 96 9 nov 15:47 /Users/marienfarge/.config – Marien Farge Jan 22 at 9:38
2

You don't have access rights for this directory. Run

sudo chown marienfarge ~marienfarge/.config
chmod 711 ~marienfarge/.config
2
  • How did it get owned by root, I'd want to know. And that directory is normally mode 711. Also, why does that tilde construct work? That should not work! But it works in ksh and bash. Sorry, side comment. Off to read shell documentation... – Marc Wilson Jan 23 at 17:00
  • Tilde + username expand to the home directory of that user. Thanks for the 711 remark – nohillside Jan 23 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .