7

Using Macbook Air M1. The keyboard Fn (Function) key has a globe icon to switch between languages. It works but a bit quirky. When it's not working, it tries to switch language but couldn't, and when I switch screen, the language switching dialog keeps popping up.

To make the keyboard Fn key work again in switching language, I have to restart my computer. See video attached - the Fn key is not even pressed.

enter image description here

2
  • 1
    With Intel MAC, BigSur, keyboards switching (input sources) is done with Ctrl+Space, set in Settings->Keyboard->Shortcuts->Input Sources. Check that and/or disable them and use Fn, or just the shortcuts.
    – Yoan
    Jan 21, 2021 at 13:55
  • ctrl+space never works the first time. Sometimes I need to try it a 2nd or evern a 3rd time and only then the keys combination gets the job done. So weird! Anyone else seeing this?
    – Tivoni
    Apr 21 at 9:46

2 Answers 2

4

Using Fn to switch keyboards is new with Big Sur. Buggy behavior has been reported by many users in the Apple discussion forums. Until Apple fixes it, probably best to use the traditional shortcuts found in System Preferences/Keyboard/Shortcuts.

I understand MacOS 11.2 should fix this problem when released.

4
  • On macOS 12.4 I still have a lot of problems with the Fn/Globe key. How it is supposed to work anyway? How should it tell if I want to use the Fn function, or if I want to change the language?
    – Wizard79
    May 25 at 9:37
  • @Wizard79 There is a setting for it in system preferences / keyboard / keyboard. May 25 at 11:29
  • That setting is for the behaviour of the Globe key and defaults to "Change Input Source", but it is still buggy as frequently pressing the Globe key does nothing. But my question was: since it is a shared Fn/Button key, when it is working as the Fn key and when as the Globe key?
    – Wizard79
    May 26 at 12:19
  • 1
    @Wizard79 Of course if you set the Fn/Globe key to Change Input Source, it is always supposed to do that. Since this is still not reliable, I recommend using Control Space or another shortcut for that, and set Fn/Globe to some other choice. Report problems to Apple via apple.com/feedback May 26 at 12:49
3

The traditional key combination for switching input sources, Ctrl+Space not only continues to work on my M1 MacBook Air, but using it once restores the Fn/Globe key back to also working.

As someone more or less new to the Mac because of the M1, I actually had no idea about the traditional key combo until hunting down this problem.

It's worth noting that in the preferences, it does mention Ctrl+Space but does not mention that Globe/Fn does it too. I suppose I must

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .