0

A month ago I made a wrong manipulation in the Network settings of my computer and since then I cannot browse any websites nor use the Mail app when I connect to my office’s WiFi or at the local café. There, I need to connect to my phone’s 4G in order to browse and check my emails normally, which obviously consumes a lot of data. Another way to be able connect there is to use a VPN. But without the VPN activated, I'm unable to connect.

When I am at home, it connects normally. So there is somewhere some incompatibility with other networks. Is it a DNS or proxy problem ? How can I solve this ?

Please help !

5
  • "I made a wrong manipulation in the Network settings" raises the question - what specific 'manipulations' did you make and did you revert them back or not. Jan 21 '21 at 13:34
  • Hi, I changed the IPv4 address manually in the TCP/IP tab of the Advanced settings in the WiFi settings in the Network menu of my Mac. I also deleted previous DNS servers and added new ones. I also unticked all boxes in the Proxys tab. Sadly I don't have a record of what was there previously. But I can tell you what is there now : TCP/IP : Via DHCP IPv4 : 172.20.10.2 Sub-network : 255.255.255.240 Router : 172.20.10.1 DNS Server : 192.168.1.252 I did that before to be able to connect to a European sever of an online game, since I could not join it because I am in China.
    – mattvent
    Jan 22 '21 at 3:01
  • Have you tried deleting the Wi-Fi service in network settings and then adding it again? That would give you a clean slate where DHCP can do its thing and the network you connect to can set the DNS.
    – root
    Jan 22 '21 at 22:48
  • @root I have deleted ("forgotten" as Mac calls this) my office WiFi and added it again after. No success. However I notice that the information is now different in the TCP/IP tab for this WiFi service : IPv4 is 192.168.1.44, sub-network is 255.255.255.0 and router is 192.168.1.1. But I'm still unable to browse any website while connected to this WiFi. Is it a DNS or Proxy problem then ?
    – mattvent
    Jan 25 '21 at 3:02
  • @mattvent I'd expect the DNS to be automatically picked up but you could try Google's DNS (8.8.8.8 and 8.8.4.4).
    – root
    Jan 27 '21 at 13:08
0

Mine does that too. Sometimes (depending on the brand of device you have) it can block unstable or WiFi networks.

1
  • Thanks, but I know it's not a random problem. It happened specifically after I tried to change the DNS settings of my computer to connect to an online game, about 2 months ago. Since then, browsers and the Mail app stopped working outside my home. However, I have no idea how to fix that.
    – mattvent
    Jan 21 '21 at 5:53
0

This seems to happen when software update of the Mac or update of the iPhone is necessary. Then it happens at other times. So, I started synching my iPhone with the Mac through Music. The problem stopped. May be it is a way to remind us to synch the phone with the Mac air. The answers of bad charger wire, dirty charging point, etc. are probably valid, but not the final answer.

1
  • Thanks, but I know it's not a random problem. It happened specifically after I tried to change the DNS settings of my computer to connect to an online game, about 2 months ago. Since then, browsers and the Mail app stopped working outside my home. However, I have no idea how to fix that.
    – mattvent
    Jan 21 '21 at 5:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .