I'm trying to revert the encryption on my disk, but Disk Utility gives me an unknown error, and from the command line, using

sudo diskutil corestorage rever UUID

It gives me this error:

Error: -69741: The target disk isn't eligible for reversion because it wasn't created by conversion or it is not part of a simple setup of exactly one logical and one physical volume

The hard disk is encrypted by me, so I know the passphrase (which is asked soon after the command, before the error). It's the main disk, on which the OS is installed, and encrypted with FileVault 2. I recently updated to Mountain Lion Developer Preview. I know this could be a bug, since it's a DP, but in my opinion the problem is related to the upgrade itself and it would be present even if I updated from SL to Lion or something similar.

This is part of the output of the diskutil corestorage list:

|   +-> Logical Volume Family UUID
|       ----------------------------------------------------------
|       Encryption Status:       Unlocked
|       Encryption Type:         AES-XTS
|       Conversion Status:       NoConversion
|       Conversion Direction:    -none-
|       Has Encrypted Extents:   Yes
|       Fully Secure:            Yes
|       Passphrase Required:     Yes
|       |
|       +-> Logical Volume UUID
|           ---------------------------------------------------
|           Disk:               disk1
|           Status:             Online
|           Size (Total):       499097100288 B (499.1 GB)
|           Size (Converted):   -none-
|           Revertible:         No
|           LV Name:            Macintosh HD
|           Volume Name:        Macintosh HD
|           Content Hint:       Apple_HFS

As you can see, it also says Revertible: No.

What should I do?

  • 1
    Need more details on the target disk. How did you encrypt it? Are you sure it's a valid image, are you able to open it?
    – stuffe
    Feb 21, 2012 at 14:21
  • There are lots of ways you can take this. Nuke and start over (if you can lose the data), post more details (diskutil list for starters and a description of what and how you made this drive to become encrypted), get support from Apple (assuming you don't want to learn whether this is a bug or intended behavior). Sorry for the "non-answer" but we might be able to work out the details in chat.
    – bmike
    Feb 21, 2012 at 14:26
  • Well, assuming that he has the encryption key, he can always copy the data to another disk before nuking the filesystem. There should be no reason to say goodbye to the data. Feb 21, 2012 at 15:10
  • Sorry if I have been unclear. I updated the post with some more information. :)
    – entropid
    Feb 21, 2012 at 16:59
  • 1
    this is not a solution to the problem but an answer how to get to such a state (I am facing the exact same problem). I created it by copying my whole encrypted disk to a brand new one using carbon copy cloner. It worked fine but the target disk was not encrypted any more and would not let me encrypt it. So I erased the target disk, formatted & encrypted it BEFORE copying anything. Then I copied again on to the already encrypted empty target disk. Worked fine also, but got me into exactly this state. Any idea how to solve this? (sorry for posting this as answer, the system does not let me comme
    – user20789
    Mar 28, 2012 at 0:07

1 Answer 1


Reversibility of encryption depends on whether you converted volume to encrypted one or created encrypted volume. So if you want the process to be reversible — create disk first, then encrypt it using diskutil. From this it seems that in your case you should copy all data to another disk, erase this one (creating unencrypted partition), encrypt it and move data back.

  • That's what I've done a long time ago, it seemed the only solution. Thanks anyway!
    – entropid
    Apr 14, 2012 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .