2

It seems like the method to increase the key repeat speed further than the settings allow as mentioned in this question no longer works in Big Sur:

How to increase keyboard key repeat rate on OS X?

Has anyone figured out a way to increase the Key Repeat speed in Big Sur?

4
defaults write NSGlobalDomain KeyRepeat -int 1
defaults write NSGlobalDomain InitialKeyRepeat -int 10

And turn off press and hold if you haven't: \

defaults write NSGlobalDomain ApplePressAndHoldEnabled -bool false

I can confirm they work because I am using these settings. Also make sure "slow keys" is disabled in System Preferences > Accessibility > Slow Keys.

Also, although it seems counterintuitive, I checked all my defaults for keyrepeat entries with defaults read | grep -i 'keyrepeat' and found that I had "KeyRepeatEnabled = 0;" in my com.apple.Accessibility defaults. So maybe setting that to 1 would override the other above defaults and prevent fast key repeat.

To match my setting you can use the command:

defaults write com.apple.Accessibility KeyRepeatEnabled -bool 0

You need to restart your computer for all of these things to take effect! Logging off and on did not change anything for me.

4
  • Are you running macOS Big Sur? Jan 20 at 3:25
  • @user3439894 yes Jan 20 at 3:30
  • Confirming this working. Running BigSur Air M1
    – outluch
    Feb 22 at 2:23
  • -bool 0 doesn't work for me, but -bool false. defaults write com.apple.Accessibility KeyRepeatEnabled -bool false
    – YLJ
    Aug 26 at 14:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .