My Magic keyboard is acting very weird. The Caps lock’s light is off and non-functioning. Mainly its alphabet, numbers, ⏎ Return, ⌘ Command work. However, the ⇨Tab, Space and Backspace keys don’t work. The right arrow key works, but if I hit the left arrow key, then it produces the following single quote: '

Is it botched, mis-configured, or is this some accessibility feature? I already forgot the device (Bluetooth) and re-connected it. That didn’t do anything

It’s just this one magic keyboard. I have another which works fine. I’ve done a reboot. Sticky keys are disabled.

When I use the keyboard viewer. Nothing gets highlighted for the space or backspace keys. Surprisingly when I click on the left arrow key, I got the left arrow and the single quote key highlighted 🤯

enter image description here

I also followed most steps from here and here but neither worked for me.

I'm starting to think that this is mainly due to the bashing my little one has done on my keyboard...

  • 1
    You kinda answered your own question. You have another one that works fine, so the issue is with the keyboard itself, not the Mac. Time to toss that keyboard. Commented Jan 18, 2021 at 14:57
  • @SteveChambers I'm not sure. It could be a mis-configuration
    – Honey
    Commented Jan 18, 2021 at 15:04
  • 1
    I don't know of any software configuration which could give the results you describe. Software configurations normally affect all keyboards the same way. Commented Jan 18, 2021 at 15:39
  • I also have a keyboard which was physically damaged and now acts strange: some key don't work at all, some keys don't output what I am typing. Since the other keyboard is working fine it sounds like hardware failure of the keyboard. You could easily test that though with another computer or even iPad.
    – X_841
    Commented Jan 18, 2021 at 16:56
  • @X_841 Great idea. I just tried my iPad and unfortunately same problem. It's no longer functional I guess. :(
    – Honey
    Commented Jan 18, 2021 at 17:00

1 Answer 1


Likely the keyboard is physically damaged by my child or water damaged. I just tried it with my iPad and same symptoms.

Sounds like a good opportunity to do a keyboard teardown

Not the answer you're looking for? Browse other questions tagged .