0

First time posting here so I'm sorry if I mess anything up.

I have a 2016 MacBook Pro Touch Bar 13" that refuses to charge or boot when the battery is connected (It will boot when plugged into the charger and even with the battery data cable plugged in, just not when the battery power is connected). With it booted (battery disconnected) everything works normal. The computer is not receiving power when the battery is connected (no haptic feedback on trackpad, lights, fans, etc.).

Opening up the computer and giving it a visual inspection shows no physical damage, corrosion or water damage on either side of the logic board. On one of the USB-C ports I noticed what looked like a little bit of corrosion so I cleaned it off.

What I've tried:

  1. Different charger cable/block (OEM)
  2. New battery (OEM)
  3. Reset SMC -This one is a little weird. When I try to reset the SMC, per Apple's instructions (T1 with non-removable battery-I leave the battery plugged in and charger connected) the computer refuses to boot unless I disconnect the battery. So I'm not sure if it's actually resetting or not.

MacOS says battery - "Service Recommended", the diagnostic (Hold R while booting) shows no problems- Reference Code:APD000 (it used to give a Service Battery before I put the new battery in), and I've attached a screenshot of CoconutBattery.

If anybody has any ideas of what else to check or to try that would be huge help. If there's any other info. that you need me to provide that I didn't please let me know. Thank you!

CoconutBattery with replacement battery installed

3
  • You have changed the battery and it still says that the status is poor/Service recommended? – X_841 Jan 17 at 21:51
  • Correct. When connecting power to the battery while the computer is booted, CoconutBattery reports it as completely discharged and receiving 0 watts of power. MacOS reports that the battery is at 1%. Checking the battery with a multimeter (assuming its as simple as touching + and - shows 0V coming from battery. – Jacob Pina Jan 17 at 22:59
  • Seeing that the battery is 4 years old, is it possible that it's gone to "sleep" from a lack of use (it's discharged to the point that the battery circuit board won't accept a charge)? I was told it was a new battery when they ordered it and CoconutBattery is showing a charge of 0 mAh. – Jacob Pina Jan 17 at 23:48
0

Solved: Battery was defective (battery entered sleep state and was unable to be woken up). Got another new battery and everything works as should.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .