3

EDIT: corrected keyboard shortcut to say ⏻ rather than ⏏

I put my computer to sleep using cmd+opt+ whenever I leave my desk.
For years, this has reliably locked the screen of the computer.

But ever since I upgraded to macOS 11 Big Sur: sleeping the computer does not lock the screen. I return to my computer later (minutes or hours), wake it up with the keyboard, and find that the computer is ready-to-use; no lock screen is presented.

Specifically, sleeping via keyboard shortcut does not lock it. Whereas sleeping by selecting "Sleep" with the mouse in the Apple menu seems to work.

My settings are the same as always:

Require password immediately after sleep begins

I'm using a MacBook Pro (Retina, 15" Mid-2014) on 11.1 Big Sur.

I have all the latest updates:

enter image description here

Is anybody else experiencing this? For my part, this is a security regression that has reduced my trust in macOS.

16
  • What Mac model specifically? I didn't think anything old enough to have an Eject button could run Big Sur. – Tetsujin Jan 16 at 17:58
  • @Tetsujin apple.com/shop/product/MQ052LL/A/…. I can't reproduce the problem though, sleeping via keyboard leads to the lock screen on wake-up. – nohillside Jan 16 at 19:05
  • Did you try to toggle the security setting (disable it, quit System Preferences, then enable it again)? – nohillside Jan 16 at 19:06
  • @nohillside I had tried toggling the security setting, but I hadn't tried quitting System Preferences in-between toggles. that actually appears to have fixed it! would you like to submit that as an answer? I don't know whether this will fix it permanently; if the problem comes back I would need to un-mark as answer. – Birchlabs Jan 16 at 19:29
  • @Tetsujin ah, if I press on the internal keyboard, then the shortcut is cmd + opt + ⏻ rather than ⏏. – Birchlabs Jan 16 at 19:33
2

Maybe the settings got corrupted when upgrading to Big Sur.

  • Open System Preferences -> Security & Privacy
  • In the General tab, disable/untick "Require password after sleep"
  • Quit System Preferences to have the changed settings written to disk
  • Open the same panel again and enable the setting
  • Quit System Preferences (and hope for the best)
1
  • 1
    Thanks @nohillside. this made it work twice in a row, but I've just now come back to find my computer unlocked, after a few hours away from it (I believe I put it to sleep prior to that). I think I'll need to continue monitoring the situation and work out whether there's any kind of pattern. – Birchlabs Jan 16 at 23:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .