0

I'm trying to recover the password of an old iMac, couldn’t boot to Recovery though. So I went into single user mode to access the files, which worked. I have an external hard drive that is formatted as Mac OS Extended (Journaled) to put the files I'm looking for on the iMac into the drive. I copied them and I went to my computer to access it. But now my drive isn't mounting!

When I did the copy I ran the command cp <file> /dev/disk1s2. When I try to mount it on the other computer to see the files, I tried mounting it through the command line with diskutil mountDisk /dev/disk2 and diskutil mount /dev/disk2s2. Both commands gave me an error saying that the disk failed to mount. I also tried mounting it through Disk Utility but nothing happens.

I need those files because it contains the password of the computer. How am I going to see the files?

0

2 Answers 2

0

Your cp destroyed whatever filesystem there was on the external disk because you copied to the device itself without mounting it first. To fix:

  • format the external disk on the other Mac (HFS+ should be fine)
  • boot old Mac into single user
  • mount the external disk (mkdir /Volumes/mydisk; mount /dev/disk1s2 /Volumes/mydisk)
  • copy the files to the mounted disk (cp files /Volumes/mydisk/)
  • unmount disk before unplugging (umount /Volumes/mydisk)
3
  • Single user mode won't let me use diskutil in single user mode. The warning says Unable to run because unable to use DiskManagement framework. Common reasons include, but are not limited to, the DiskArbitration framework being unavailable due to being booted into single-user mode Jan 16, 2021 at 15:53
  • @MatthewSchell You can also just use mount then
    – nohillside
    Jan 16, 2021 at 16:11
  • Even after running /sbin/mount -uw, the filesystem is read-only. Can't create directory Jan 16, 2021 at 16:25
0

I'd recommend using target disk mode to copy the files to a location that's available on your working computer, eg. a properly formatted & mounted external drive.

6
  • Actually, I don't have a thunderbolt cable Jan 16, 2021 at 0:36
  • @MatthewSchell are you on macOS 11.1.x Big Sur?
    – Scottmeup
    Jan 16, 2021 at 1:23
  • No, the iMac with the account I want to recover the password for has Mac OSX 10.6.8 and the other macbook that I want to use to recover the password for the iMac is macOS Mojave 10.14.6 Jan 16, 2021 at 1:49
  • @MatthewSchell then you don't need a thunderbolt cable
    – Scottmeup
    Jan 16, 2021 at 4:49
  • How would I connect it then? By USB Cable? Jan 16, 2021 at 5:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .