8

Recently, Google Chrome keeps loosing the ability to detect my location. When I open Google Maps, it has the icon indicating This site has been blocked from accessing your location and when I click it, a dialog containing Location is turned off in Mac system preferences is shown:

Location is turned off in Mac system preferences, This site has been blocked from accessing your location

So I have to go to Enable Location Services:

Need to Enable Location Services for Google Chrome again

But I am sure that I have done this several times recently. It seems that this setting is lost regularly (maybe for every Chrome auto-update?). How can I make this setting permanent?

4
  • What version of macOS are you on? I have the same issue with Chrome 87.0.4280.141 on macOS High Sierra 10.13.6.
    – cpcallen
    Feb 5 at 22:37
  • Right now I am on macOS Big Sur version 11.2 and Chrome 89.0.4389.40, but I haven't had this problem for a while now (couple of weeks?), so it may have gone away. Feb 5 at 22:42
  • I have the same problem and it annoys the hell out of me... I just updated to Chrome 89 and sure enough, had to enable it again. I'm beginning to think this is more of a Chrome than a Big Sur / MacOS thing...
    – RobIII
    Mar 12 at 19:57
  • Duplicate of: apple.stackexchange.com/questions/408430/…
    – Carl Walsh
    Apr 14 at 18:13
5

This is tracked here (I think.) Sounds like it's fixed and hopefully will be corrected in a coming chrome version.

2

This setting is permanent from the System's perspective, so this is a bug with Google Chrome. You're probably right that the auto-update process is causing problems.

You can try completely uninstalling Chrome and installing it, since that might fix some installation issue that was causing this to manifest.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .