1

I'm trying to reinstall macOS to a seriously messed up MacBook Pro 2018. Apparently, problems started initially when the Big Sur update failed. The computer's disk has since been erased and all accounts have been lost. The computer shows a question mark folder when it's started.

Here's what I've tried so far:

  1. Started Mac to startup manager (press Opt in startup). No disks are showing, the only option is internet recovery, which fails.
  2. Started Mac in recovery mode and ran First Aid on the disk, which says that the volume appears to be OK. In addition to internal Apple SSD, there is a macOS Base System Disk Image.
  3. Also in Recovery Mode, I've run the command bless --info and bless --getBoot which both return Can't access "efi-boot-device NVRAM variable.
  4. Reset NVRAM and SMC, which had no effect
  5. Tried to install macOS from a bootable drive, which failed because the external boot is disallowed in Startup Security Utility. I cannot change the setting because there is no administrator account.
  6. Tried to start into single user mode (Cmd+S), to remove /var/db/.AppleSetupDone file in order to run Mac setup again and get new admin account. Logging into single-user mode fails, apparently because there is no startup disk (based on Unable to enter single user mode (to create Admin account)).
  7. Tried to set startup volume in recovery mode terminal by running command bless -mount /Volumes/Macintosh\ HD/ -setBoot which returns the following:
Can't load /Volumes/Machintosh HD/usr/standalone/i386/apfs.efi
Could not load apfs.efi data from /Volumes/Machintosh HD/usr/standalone/i386/apfs.efi

Any ideas on what I should do? I'm guessing that the first thing I need is to get the startup disk working and create an administrator account. However, that seems to be easier said than done.

11
  • Can you create a USB installer and try to install macOS from there?
    – X_841
    Commented Jan 14, 2021 at 22:07
  • When booting in single-user mode did you mount the disk before attempting to write to the drive? Commented Jan 14, 2021 at 23:46
  • @X_841, Yes, I have bootable USB installer made (I made it following these instructions: support.apple.com/en-us/HT201372). However, I cannot use it because booting from external media is disallowed. To change that I need an administrator account, which I don't have. To create an administrator account I need to get into single user mode, which I can't get into because the computer does not have a startup disk.
    – Kilipukki
    Commented Jan 15, 2021 at 6:26
  • 1
    The mac is new enough for the installer to be accessible from ROM using the appropriate key sequence while booting. See support.apple.com/en-us/HT204904 for details. Be certain that the disk is completely erased. Commented Feb 14, 2021 at 8:54
  • 1
    I took the laptop to authorized repair. They ran diagnostics on it and memory modules failed the tests. Apparently they had failed for some reason so they ordered new motherboard for the computer. Luckily warranty still covered it.
    – Kilipukki
    Commented Feb 15, 2021 at 10:39

1 Answer 1

0

Agree with X_841. It sounds like you need to create a USB installer disk and reformat the hard drive or SSD from there.

2
  • I have created the USB installer. The problem is that external booting is disallowed in Startup Security Utility. To change that, I need admin account, which I don't have. And to create one, requires access to single user mode, which I cannot acccess because of missing startup disk.
    – Kilipukki
    Commented Jan 15, 2021 at 6:35
  • 1
    This is not a good answer. You just took my comment and added no info, not even how to do a clean install. Also OP has now stated several times this approach doesn’t work.
    – X_841
    Commented Jan 15, 2021 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .