0

I have just purchased VMware Fusion Pro 12.1.0 on MacOS Catalina 10.15.7.

I want to run a MS Edge Legacy virtual machine, available from Microsoft here: https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

I have tried the virtual machines for Win10, Win8 and Win7. The problem seems identical or very similar with all.

I create the machine from the .ovf file in the downloadable zip, in Fusion Pro, via New > Import an existing virtual machine. The .vmdk file included in the zip is grayed out and cannot be selected. Import of the .ovf seems to finish successfully according to the Wizard.

However, when attempting to Start Up the machine, nothing happens even when I wait a long time. First Fusion says "Loading..." for several minutes. After that, a black window opens with a "Play" icon. When I press it, I get the question: "Would you like to upgrade this virtual machine?". I have tried pressing both "Don't Upgrade" and "Upgrade" with the same problems, so it doesn't appear to help.

Next, the virtual machine window stays black with a grayed-out "Play" icon. I wait and nothing happens. In the Fusion main window, I see the clickable option "Clean Up Recommended" immediately after attempting to start the machine.

Under the Menu option Virtual Machine, it says "Windows is off" and on the next row "Starting Up". "Restart" and "Shut Down" are grayed out. The button "Power On To Firmware" is clickable but doesn't seem to do anything.

If I try to close the machine window or quit VMWare completely, it refuses to close the window and/or app, and says: "The virtual machine "MSEdge-Win-10-VMware" is busy". After a very long time, an error message appears:

"Failed to power on /path/MSEdge-Win10-VMware.vmx".

If I want to exit before this long wait, I have to Force Quit the application to get out. After restarting the application, I cannot Delete the virtual machine unless I've first deleted the newly created .vmwarevm file on the drive.

I previously used the Trial version of Fusion 11 with no problems on the same computer and virtual machines. Yet, Fusion 12 does not seem to work.

enter image description here

4
  • Why did you purchase VMware Fusion Pro 12.1.0? Why did you not use the free VMware Fusion Player? – David Anderson Jan 14 at 22:35
  • The free player is only licensed for non-commercial use. – Marc Wilson Jan 15 at 0:29
  • So that would mean I should not try to answer your question since I am using the free version. VMware website states: Complimentary support for VMware Fusion Player and VMware Fusion Pro is valid for 30 days from product registration. I assume this is only for paid for versions like yours. See here – David Anderson Jan 15 at 22:00
  • If Fusion 11 works and Fusion 12 does not, then why not just use Fusion 11? I am using the free Fusion 12, but I can download versions 10, 11 or 12. – David Anderson Jan 15 at 22:07
0

It appears the VMWare Fusion .dmg installation image file was put under the MacOS Quarantine, which made the application not function properly.

Uninstalling VMWare Fusion (I removed all files with AppCleaner), downloading the .dmg file again, and then running the following commands on the file, followed by running the installer solved the issue for me:

xattr -l ~/Downloads/VMware-Fusion-12.1.0-17195230.dmg
xattr -dr ~/Downloads/VMware-Fusion-12.1.0-17195230.dmg 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .