1

EDIT: Found some files, not sure if deleting them will fix the issue though. Does anybody know if I can just delete these?: enter image description here


For a couple months now, I've been getting this error, periodically, a few times a day, randomly. It's been happening ever since I've gotten my new Macbook (I did the thing where I connected both laptops with a USB-C and copied everything over the first time i launched the new laptop)

enter image description here

Never have I ever, on this laptop, or in my last laptop, installed this before, to my knowledge. I have googled the error and found nothing

This application also does not exist in /Applications or ~/Applications, and there's no process that looks like this in Activity Monitor.

I also did a disk search with sudo find / -name network and there were 0 hits that looked like this could be it

I also checked login items in my Account preferences, and this doesn't exist either.

Even if I restart my machine, it will eventually show up again

I also do not run much on my machine. Here are my login items, and besides that day-to-day I use Xcode, SourceTree, and Chrome.

In the past I have used Shadow App and Parallels, I'm thinking maybe one of those apps may have placed something in that was just sleeping, and then got backed up onto my new machine... but I still can't find anything.

Does anybody know how I can troubleshoot this further? it's been driving me crazy! enter image description here

1

This may be caused by extensions that were installed when the Eltima USB Networks Gate for Mac application was installed.

A couple of possible solutions I found:

This one from an Eltima forum which it's recommended to run in safe mode:

sudo /Library/Frameworks/EveUSB.framework/Support/uninstall

The other is from a Stack Overflow post that provides a script for finding and removing any Eltima USB Networks Gate for Mac extensions.

1
  • Thanks for digging those up! So I tried both, but unfortunately there is no uninstall... i'm going to add details into the question. Not sure what I can do from here, if I can just delete these files?
    – A O
    Jan 14 at 17:20
0

Well it's been a week and it hasn't shown back up, so here is the solution:

rm /Library/Frameworks/EveUSB.framework

There was no uninstall script, so I just removed the entire framework and the problem disappeared. I have no idea what was trying to run this framework, from my googling it seems best guess is Shadow App (VM for gaming), which I installed a year ago, but never noticed until I updated my macOS and these security popups started showing up

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .