0

Out of all of the problems I’ve had, this one has been the most stubborn.

When I first installed Catalina, it seemed to work mostly fine except for one thing: Siri wouldn’t open. It would try over and over, generating thousands of crash reports if I left it long enough, all saying the same thing:

Termination Reason:   DYLD, [0x4] Symbol Missing
Dyld Error Message:
symbol '_OBJC_CLASS_$_SiriUIDismissalOptions' not found, expected in '/System/Library/PrivateFrameworks/SiriUI.framework/Versions/A/SiriUI', needed by '/System/Library/CoreServices/Siri.app/Contents/MacOS/Siri'

I first tried to reinstall macOS, but to no avail.

Some googling of the issue told me that it was a dependency issue - but I can’t find anyone else with a similar issue that didn’t fix it by reinstalling.

I reinstalled again. Nothing. I tried replacing the file SiriUI it wanted a symbol from with a known working version from Mojave from a time machine backup. That still didn’t work.

How can I fix this, when neither a reinstall or known working file did? Is there any way to add the symbol to the file, or make it visible to the Siri app if it’s already there?

You must log in to answer this question.

Browse other questions tagged .