2

I have a 21.5 inch retina iMac (2017) which has a malfunction internal SSD, so Ive been using it with a SAMSUNG external SSD connected via USBC/Thunderbolt port to the iMac.

This has been working for a couple of years now, the problem is that I was on Mac OS Mojave and when I want to update either to macOS Sierra, HighSierra or Big Sur, the installation process fails and enters in one of the following scenarios:

  • Message "Your computer restarted because of a problem" when installing, this generates an infinite loop and the installation is never finished.
  • Just a infinite loop, for example when is in "Installing software update X%" it restarts and enters in a infinite loop.

I've tried installing macOS with a Bootable USB and with a Software update from Mac OS Mojave, none of this works.

Is there anything that I can do? If I go and install Mac OS Mojave, everithing goes well.

Also is important to mention that anytime I try to do a bootable USB installation, I erase the SSD to "AFPS" and rename it to "Macintosh HD".

Thanks in advance

1
  • 1
    I am facing the same issue trying to install Big Sur on external flash drives. I tested it with a flash drive from SanDisk and Samsung and on a MacBook Pro 2018, as well as a MacBook Air 2015. I tried installing via App Store download as well as internet recovery, both result in an infinite reboot loop / kernel panics. Installing Catalina works fine on either one of them. Then performing an update via the App Store results in an endless reboot loop again. Mar 9 at 18:04
0

Apparently the Big Sur installer has issues with certain external drives. I tried installing Big Sur on external flash drives (SanDisk and Samsung), neither a fresh install, nor an update from Catalina worked (resulted in endless reboot loops or kernel panics).

I ended up installing 11.2.3 on an external HDD (from LaCie). Although I also got a kernel panic on the 2nd reboot that occurs during the install, it rebooted and went on to finish the installation without further issues. I then used CarbonCopyCloner to clone the HDD onto the flash drive and was successfully able to boot and use the system.

(You might be able to perform the clone with disk utility as well.)

1
  • Back to the reboot loop after running an update to 11.3 May 1 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .