0

Background: Upgraded to Big Sur on 2020 MacPro (not the one with M1 chip), hate it, trying to revert to Catalina using a USB bootable installer (followed instructions given at the Apple website How to create a bootable installer for macOS)

When I try to install it using the external drive, I get this screen. enter image description here

So it seems that my USB has the wrong scheme (should be GUID). I go to Disk Utility and sure enough, it seems like it's Master Boot Record as shown below.

As per the suggested screen, I try to Erase it, but whenever I try to do that, I get the error shown below.

I'm unsure about how to resolve this and I can't seem to find someone who experienced the same error online. The USB is a brand-new 32GB SanDisk

3
  • 1
    I inlined one image, perspective crop & legibility push - ran out of time to do the others, end of day for me ;)) – Tetsujin Jan 10 at 20:00
  • Why are you trying to install the OS to the external USB and not the internal SSD? If you are trying to revert to macOS Catalina and have the macOS Catalina installer on the USB drive, then install it to the internal SSD. – user3439894 Jan 10 at 20:09
  • 1
    @user3439894: I have a 2018 iMac with Mojave and Big Sur installed to separate volumes in the same container. The startup disk pane of system preferences under Mojave does not show Big Sur. Assuming Catalina has the same problem, then this would explain why the Big Sur volume does not appear in the image in the OP's question. – David Anderson Jan 10 at 20:17
2

This answer first explains the traditional method of using the Disk Utility to solve the OP's problem, which in this case does not work. Next, the alternative method of using the diskutil command is given. This alternate method did work when tested in a VirtualBox virtual machine on a 2013 iMac.

There is no reason the flash drive installer can not use the Master Boot Record Scheme. Your problem is you are trying to install macOS to the flash drive. Normally, you would need to open the Disk Utility after booting to the installer (hold the option key at startup) and erase the internal drive. Afterwards when you return to the point shown in the image, then there should be an icon for the internal drive.

Below is an example of the result after highlighting the internal drive and clicking the Erase button at the top of the Disk Utility main window.

Note: The image below shows the Device for the internal drive is disk0. If your Mac shows a different Device, then make the appropriate substitution when entering the diskutil command given below.

enter image description here

Before clicking on the Erase button, you would need to change the Name and Format. Below is an example.

Selecting the Erase button on the pop window should cause the internal drive to be erased. In this case, nothing happens. The solution is to select Cancel, quit the Disk Utility, open a Terminal window and enter the following command.

Note: Here I have assumed the internal drive is disk0. This should be true unless there are additional external drives attached such as a thunderbolt 3 drive.

disktuil erasedisk apfs "Macintosh HD" gpt disk0

As example is shown below.

When finished, quit the Terminal application. When installing Catalina, you should reach a point where you can choose Macintosh HD, as shown below.


Note: Erasing the internal drive will delete all data stored on it. Be sure to backup your system first!

You could also try using the Disk Utility to add a new volume to the existing container on the internal drive, then choosing to install Catalina to this new volume. This would create a dual boot arrangement that would not erase your existing data.

3
  • Makes sense. Assuming by "internal drive" you mean the "APPLE SSD..." thing. When I try to click "Erase" on the internal drive, nothing happens (no pop-up or anything). I've already backed up my information – Anthony Jan 10 at 20:32
  • Anthony: you have a good point. I verified your results and updated my answer with an alternative solution. – David Anderson Jan 10 at 22:45
  • Thank you! Just tried your solution and it worked!! – Anthony Jan 12 at 0:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .