0

I need to view a video in "mp4" format with an accuracy of minutes, seconds and milliseconds for a specific task - analysis.

Operating system: macOS Catalina, version: 10.15.7

As I understand there are video players with milliseconds display only on windows, on Mac, alternatives and solutions could not be found. Maybe someone came across a similar question and was able to solve it. I have already tried to install the VLC player, but a certain plug-in is needed to open the ability to view in milliseconds, unfortunately I could not install such a plug-in on a Mac.macos video

This error occurs when trying to open the file:

enter image description here

The document "2020-12-24T09_20_45.375Z_LR_crf_26_deidentified.h.265.mp4" could not be opened.

The file isn't compatible with QuickTime Player.

  • Which ones have you checked? Saves us having to duplicate... – Solar Mike Jan 10 at 12:21
3

If you have homebrew installed, you can install mpv (recommended) or IINA (based on mpv) which displays milliseconds.

If you do not have homebrew then you can install it by copying pasting the following in your terminal:

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"

Solution 1: Install mpv with the following command:

brew install mpv

mpv player supports url and a wide variety of video formats. That means you can play files locally as well as youtube or any other online video links straight from your terminal.

After installing mpv you can play your video file by going to the terminal and type:

mpv <Drag the file you want to play from finder and hit enter>

At the beginning when mpv will open, it will not show you milliseconds. You would have to click on top of the time for it to display milliseconds.

For details see: https://mpv.io/ and their git repo: https://github.com/mpv-player/mpv

Here is a screenshot of a non-copyright video playing from youtube with milliseconds displaying at the bottom:

enter image description here

Solution 2: Install iina with the following command:

brew install --cask iina

It should let you install version 1.1.2 which supports this feature.

You can choose the timestamp in miliseconds as shown in the following screenshot:

enter image description here

1

The open source app IINA (on GitHub) is imo the best media player for macOS. It's handled all video formats I've thrown at it, and is handier for playlists etc., so I think it would be worth having even if you didn't have this particular problem of wanting to see milliseconds.

You can install it from its website or with Homebrew: brew install --cask iina.

To make it show milliseconds, right-click the current time at the side of the video's scrubbing bar. It will show a "Precision" drop down. Select milliseconds to see the timestamp with milliseconds.

enter image description here

enter image description here

0

You could open your video in QuickTime and use the trim view (Cmd+T) to see the milliseconds.

  • The fact is that QuickTime is not compatible with mp4 :(( – Ekaterina Andreeva Jan 10 at 13:31
  • 1
    @EkaterinaAndreeva mp4 is one of the few formats that quicktime is compatible with – theonlygusti Jan 10 at 14:01
  • @theonlygusti When I try to run file 4, the player shows an error that the file is incompatible and cannot be run. – Ekaterina Andreeva Jan 10 at 14:28
  • @EkaterinaAndreeva then the video is in an incompatible codec. You should install ffmpeg (brew install ffmpeg if you have Homebrew) and then ffmpeg -i your_video.mp4 output.mp4, then you can open output.mp4 in Quicktime and use TwlvSeconds' answer. – theonlygusti Jan 10 at 14:34
  • It looks like this rounds to centiseconds. – theonlygusti Jan 10 at 14:50
0

You don’t strictly need milliseconds displayed. Your video has a video frame rate: 24, 30, 60, are standards. The standard SMPTE time code gives hour, min, sec, and frames. Divide the frame by the frame rate and that gives you the decimal seconds.

Unless the video was shot at a high frame rate — which even phones can do nowadays — you won’t actually have millisecond precision. So be careful to not misrepresent the actual precision — make the uncertainty clear.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .