1

I am using Big Sur. Inside the Messages app when I click the green circle in the upper left hand corner while holding the Option key the green icon will display a black plus (+) sign and the window will maximize to take up the whole screen except the dock and the menu bar. I call this Maximizing the window.

This same functionality does not work in Safari. In Safari I use the same key combination and the green circle shows a plus (+) symbol when the mouse hovers over the icon, however when I click the Safari window does not expand all the way. It only uses about 60% of the horizontal area of the screen instead of the full 100% of the horizontal area.

Is there a way to correct this? It is very annoying to have to manually drag the edges of Safari to fill up the screen.

1
  • 1
    Safari has never maximised to the entire screen, it's not new to Big Sur. – Tetsujin Jan 8 at 18:35
0

If you hover over green circle while not in full screen you should see following options:

enter image description here

'Zoom' is the option which should deliver result you are calling 'Maximizing the window'. These options are also available under 'Window' on Menu bar (by default keyboard shortcuts are for Tile Left/Right, others must be set).

Shortcut for Full screen is + + F. Using it while in Full screen reverts window back to initial size before going fullscreen.

6
  • Does this "Zoom" feature work for you in Safari? I see the Zoom option but it does nothing in Safari. It works in other apps such as Messenger and Reminders but not in Safari. I am on Bug Sur v11.1 – webworm Jan 8 at 20:21
  • Yes, it works in Safari for me. As well as ⌥ + click. – Aivar Paalberg Jan 8 at 20:39
  • Strange .. it does nothing for me. I have tried using both an external monitor as well as the built in screen. – webworm Jan 8 at 20:56
  • I created new account and it really didn't work by default. But after I set keyboard shortcut for Zoom, it started to work. However, it didn't expand all the way as you described. Then in 'Zoom' state I manually dragged window to maximized size, exited Safari and opened it again. Then it worked as described above i.e. Zoom maximized Safari window and Zoom again restored initial size. – Aivar Paalberg Jan 8 at 21:13
  • @AivarPaalberg How do you get that menu? When I hover the green icon, no menu appears for me. – sfxedit Jan 9 at 9:08
0

I finally got it to work in Safari. Move the mouse cursor all the way to the corner of the Safari window. The cursor should change to and angled arrow with two ends. If you double click while the cursor is a double ended arrow the screen will expand to one side of the screen depending on which side of the window you are clicking on (left or right). Hold the option key while double clicking the arrow to expand out both sides.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .