2

I need to disable iMessage from my MacBook and iPad. No matter how many times I utilize the Apple ID and password request in iMessage on my MacBook and iPad, I find it open and running almost everytime I log on. I share these devices with someone and have told him I only want messages on my iphone. How can I take care of this once and for all? please and thank you?

1 Answer 1

4

To disable Messages on iPad:

  • Open Settings.
  • Tap on Messages.
  • Tap and turn off iMessage to disable it.

Next, let us disable iMessage syncing your messages on your iPhone to your iPad. Again in Settings:

  • Tap your Name / Apple ID.
  • In Apple ID, tap on iCloud.
  • In iCloud, under 'Apps using iCloud', tap and turn off Messages.

Next, let us make sure nobody else but you can enable iMessage on iPad again. So, again in Settings:

  • Tap Screen Time.
  • In Screen Time, tap Turn On Screen Time.
  • Tap Continue.
  • Select This is My [device].
  • Tap Use Screen Time Passcode to create a passcode, then re-enter the passcode to confirm. (Note: This should be different from the passcode you use to unlock your iPad, and don't tell it to anyone you are sharing your iPad with. You maybe asked to enter your Apple ID and password. This can be used to reset your Screen Time passcode if you forget it.)
  • Now tap on Content & Privacy Restrictions. (If asked, enter your passcode).
  • In Content & Privacy Restrictions, scroll down to the section Allow Changes and tap on Account Changes.
  • Tap on Don't Allow.

That's it - now,

  1. You have disabled iMessage on iPad.
  2. Made sure that the messages you send and receive on your iPhone is not synced and available on Messages on iPad.
  3. With Screen Time you have made sure nobody can enable iMessage again on your iPad (as long as they do not know your Screen Time passcode).

To disable Messages on your macOS:

  • Open Messages.
  • From the menu bar on top, Click on Messages > Preferences...
  • In the Preferences window, click on iMessage.
  • Then click and uncheck Enable this account and Enable Messages in iCloud.
  • Then click on Sign Out.

On macOS Mojave:

Screenshot of macOS Mojave iMessage Preferences

On macOS Big Sur:

Screenshot of macOS Big Sur iMessage Preferences

(Screenshot from Apple support docs - the id and phone number are fake).

Now Messages should be disabled on your macOS too, and unless someone knows your Apple ID and password, they won't be able to enable and access it.

(If you want to share your macbook with someone else regularly, create another user account for them. Learn how to do this here - Set up users, guests and groups on Mac).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .