0

I'm using a 2015 MacBook Air running macOS 11.1 and Safari version 14.0.2, and I'm trying to clear my Safari cookies. I've opened Safari, then gone to Safari -> Preferences -> Privacy -> Manage Website Data... then I've clicked on specific sites and clicked Remove. I've also clicked on Remove All, then Remove Now on the pop-up asking to confirm. Both of these do absolutely nothing. Many other users online have described their problem to be that the cookies disappear, then shortly reappear; this is not my problem. My problem is the cookies never disappear in the first place (none of them).

I've tried the following things to resolve the issue, with no success:

  1. Quitting Safari, then restarting it.
  2. Restarting my computer.
  3. Checking to make sure my computer, and Safari are both up to date.
  4. Booting up my computer is Safe Mode.
  5. Turning off iCloud Safari syncing.
  6. Clearing the cookies and other website data on my iPhone.
  7. Turning on Block all cookies under Privacy in Safari Preferences.
  8. Clicking on Develop -> Empty Caches.

I've noticed there are folders named Cookies and Safari in the Library folder. However, since I don't know exactly what I'm doing, I don't want to go deleting things in either of those folders.

How can I either delete my website data another way or (preferably) fix the issue of the Remove and Remove All buttons not clearing my website data?

2
  • Have you tried to use 'Remove' two times in a row on same website? While trying to replicate this behavior I encountered one website which required removal two times (separated by 'Done'). Other websites data was removed on first attempt. So I can confirm that there might be something. Jan 6, 2021 at 21:44
  • Yes, I tried removing the same website twice in a row. That made no impact.
    – Evan93
    Jan 31, 2021 at 15:38

0

You must log in to answer this question.

Browse other questions tagged .