6

Since upgrading to Big Sur, my default keyboard input during the login screen is always 'U.S.'. I need to manually switch it to 'French'. Is there a way for me to set 'French' as defaut?

In fact, I do not even know where this 'U.S.' input comes from. Here are my Big Sur regional configurations. They are as I want them and work fine once I am logged in.

  • The primary language is 'English (UK)'. All menus and system messages are in English.

  • The region is set to 'France (custom)'.

  • The keyboard primary input source is 'French'. I have other input sources, such as 'Russian - Phonetic', that I switch to occasionally. I do NOT have any English language input source, including 'US'.

To sum up: all my regional, keyboard and input settings in Big Sur works fine EXCEPT during log in, when the default layout is wrong.

Thanks in advance in helping solve this problem.

PS: The following link suggests a solution for the very same problem but it dates from 01/2014 and it's solution does not work with Big Sur.

https://vkritis.blogspot.com/2014/01/change-default-keyboard-of-osx-login.html

1
  • Have you try the terminal command sudo languagesetup then choise the language you want?
    – user415185
    Sep 25, 2021 at 11:31

3 Answers 3

2

For me the one that actually worked was:

  1. First change completely Mac OS X system language (in Language & Region) to desired keyboard language layout. In my case it was Finnish (even though I use English as my Mac OS X preferred language normally)
  2. Make sure that you have in your (Keyboard -> Input Sources) your desired input language as first option (in my case it was Finnish)
  3. Then reboot your computer
  4. After reboot, run: sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/
  5. Change system language back to the desired one (in my case English)
  6. Reboot your computer once again
1
1

For your consideration:

  1. Start by going to System Preferences: Keyboard: Input Sources, and make sure your preferred language is included in the list. Remove any unwanted languages from the list.

  2. Go to System Preferences: Users and Groups: Login Options. Unlock the preference pane if needed.

  3. Toggle the “Show Input menu in login window” option off and on again. (Toggle it on if it wasn’t already enabled.)

  4. Go to System Preferences: Language and Region: General: Preferred languages.

  5. Temporarily add a second language to the list using the Plus button. You’ll remove it later so just add any language.

  6. Drag the new language to the top of the list.

  7. Click the new Gear button that appeared on the bottom bar when you rearranged the language list, and choose Apply To Login Window. (As shown in the above screenshot.)

  8. Drag your preferred language back to the top of the list again.

  9. Repeat step

  10. Remove the language you temporary added to the list by selecting it and clicking on the Minus button.

  11. Reboot your Mac.

2
  • @user3781201 let us know if you find any answers helpful it would serve as an assistance for others too.. Sep 30, 2021 at 2:39
  • 1
    Dragging the languages of the Preferred languages list around and then placing my desired language back at the top was enough for me.
    – EpicVoyage
    Nov 29, 2021 at 16:36
0

If you have FileVault activated and are struggling to set your desired language on the login screen try the following:

  1. Turn off FileVault
  2. In terminal execute this to copy your keyboard settings to the login screen sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/
  3. Turn on FileVault again
  4. Reboot

Tested on Big Sur

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .