During the holidays, I decided to upgrade from Catalina to Big Sur (macOS 11.1 (20C69) to be precise). The one thing I did not account for is that VirtualBox stopped working.

I followed the usual advice of using the VirtualBox_Uninstall.tool script to remove any trace of VirtualBox, rebooting, installing the latest stable version from a VirtualBox-6.1.16-140961-OSX.dmg disk image, ... which fails. The install does not complete. I'm apparently not alone in experiencing this. Afterwards, VirtualBox is present on the file system however. Trying to start it works, although not booting up VMs. This fails with a rather expected

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

error message. After dismissing it, the VM process crashes (throwing EXC_CRASH (SIGABRT)).

I then tried pretty much everything in the giant thread out it on the VirtualBox forums. Nothing works for me. The test versions also do not work at all, despite completing the installation.

All other articles and forum entries as well as Ask Different questions were either dismissed because the author was using a pre-release version of macOS 11 or describe situations that, to the best of my understanding, simply cannot occur on Big Sur. Like manually accepting kernel extensions via System Preferences > Security & Privacy. As far I can gather, kernel extensions are no longer supported in Big Sur, hence the breakage of software that relies on them, like VirtualBox.

I need VirtualBox for my Vagrant development boxes. For the time being, it means I'm dead in the water, probably having to re-install Catalina from scratch or buy both a VMware and a VMware Vagrant plugin license.

Maybe someone else has experienced the same issue as I have and can shine some light on the steps taken to get stuff working on Big Sur. This answer did not work as well for me.

Edit: For the time being, VMware Fusion plus the Vagrant VMware plugin appear to do the job quite nicely. And by purchasing the plugin, I'm actually supporting OSS development of Vagrant. Additionally, VMware appears to be quite a bit more performant compared to VirtualBox. Oh well, I guess that's what you get for running something like macOS as a development machine and update too early. Lesson learned: I'm going to trail macOS releases by a full year from now on.

Edit 2: VMware Fusion has issues with Vagrant creating private network addresses. This fails with a "Failed to create new device" error and Hashicorp support has no idea what may be wrong. However, after a full disk wipe and clean install of Big Sur, suddenly VirtualBox installs just fine and runs as expected — meaning, like before. No issues with private networks as well and no SIP messing around or the like required. Just initiated a refund for the VMware plugin license. It's pretty clear that the OS updater breaks stuff in subtle ways that are hard to troubleshoot. My suggestion to someone in a comparable situation: backup your system, wipe it, make a clean install and rebuild it from scratch (not a Time Machine backup). Now the only issue are random kernel panics on restart, even on the clean install. Oh well...

  • none of the below answer working for me on my MacBook Pro running Big Sur
    – Satish
    Commented Jun 25, 2021 at 3:09
  • Wipe your disk and make a clean install, do not recover from Time Machine or any other automatic backup. It will work if you have a virgin install with no settings adjusted. Commented Jun 25, 2021 at 6:36

6 Answers 6


Big Sur user here (11.1), running VirtualBox 6.1.16 and Vagrant 2.2.14. Currently have a VM running, no issues. The major hassles for me came a few OS versions earlier (Catalina), presumably due to tightened macOS security, so may be why it was smooth for me to update to 11.1.

Per the mentioned thread, did you try this?

  • go to system preferences > security and privacy
  • unlock to make a change
  • unblock Oracle (might need a restart)
  • Install Virtualbox again
  • Linux VM started properly
  • 6
    I‘m not even seeing the „Unlock Oracle“ dialog. No, and csrutil clear does not work either. Commented Jan 5, 2021 at 22:41
  • 1
    This has nothing whatsoever to do with Vagrant. VirtualBox cannot find the kernel extension and refuses to start any VM. Also, VB uninstall and reinstall does not work as the process aborts. This is all in the issue description. Commented Jan 6, 2021 at 17:18
  • I can confirm there is something amiss as of 11.4 on my 2019 MBP 16" while 11.2.3 is working fine for me on my 2018 MBP... and I have near identical configs on these machines as I use automated CM with ansible for nearly every change made to the system. I'll see if I can figure out what's up with the 2019 MBP (which also worked prior to upgrading to 11.4). It was right after switching that I had all kinds of random havoc with existing VMs.
    – Wes
    Commented Jun 6, 2021 at 21:44
  • This is not working period, everyone saying enable security but in my case its not showing that option even i manually add Oracle in allow list but no luck. look like its not worth upgrading Big Sur
    – Satish
    Commented Jun 25, 2021 at 3:12

Upgraded High Sierra to Big Sur 11.2.3 and encountered same failure. Without research, first updated to latest VirtualBox 6.1.18, then to vagrant 2.2.14, but same issue persisted, and then came across this topic.

Opened "System Preferences" -> "Security & Privacy". Found a message "System software from developer "Oracle America, Inc." has been updated. Clicked "Allow", then it asked for reboot so rebooted.

VirtualBox from vagrant then started up without any issue without reinstalling VirtualBox.

Security and Privacy panel

  • 1
    As I had stated several times already, including the main question, this never appeared for me. Please read carefully before just posting what other already did. Commented Mar 22, 2021 at 14:33
  • 1
    It is likely with newer Big Sur release and VirtualBox, this user friendliness was added later but was not available when you performed your upgrade. I added this reply for the benefit of people like me who encounter this issue NOW, and then google for that kernel extension error and find this topic, which ranks high on google search. Note that this procedure was mentioned by @karolus, but I experimented without reinstalling VBox and it worked, so there is added information here, and make this topic useful for wider audience, while it is totally useless information for you.
    – hshib
    Commented Mar 22, 2021 at 14:56
  • I am not seeing this warning on my Big Sur version.
    – Satish
    Commented Jun 25, 2021 at 3:08
  • Just updated to BigSur 11.4 and the preference option to authorise Oracle doesn't appear anymore, I had to disable CSR and disable kext-consent as explained above. macOS is becoming more rubbish by the day.
    – zakmck
    Commented Jun 29, 2021 at 12:24
  • I'm on Big Sur 11.5.2 and this worked for me. I actually ignored the "Allow" the first time I installed and started up VirtualBox, but then I couldn't run any virtual machines with OP's error popping up. I had to uninstall VirtualBox (using the provided uninstall script) and then reinstall VirtualBox. The "Allow" then appeared and the virtual machines worked. Commented Sep 5, 2021 at 21:18

You just follow this process to get VBox working see source:

Reboot into Recovery Mode, authenticate, open a Terminal session, run the following, and then reboot:

spctl kext-consent add VB5E2TV963

When you log back in, Open System Preferences and go to Security & Privacy

Click on Details under "Some system software requires..."
Check the box next to Oracle America...
Click OK
You will be asked to restart

Once restarted, your Vbox will be working:

  • I didn't need to do "spctl kext-consent add VB5E2TV963". It is working just by checking on security and privacy panel and reboot. After that if I do "spctl kext-consent list", I get "spctl: no kext consent configuration found.". Also user consent is enabled "Kernel Extension User Consent: ENABLED".
    – hshib
    Commented Mar 22, 2021 at 15:13
  • I'm a little confused because I thought that UI is a wrapper for doing "spctl kext-consent add VB5E2TV963" under the cover.
    – hshib
    Commented Mar 22, 2021 at 15:15

As far I can gather, kernel extensions are no longer supported in Big Sur, hence the breakage of software that relies on them, like VirtualBox.

To be clear, it is not that they are "no longer supported" in Big Sur. It is just that Apple has decided that they want to discourage developers and users from adding kernel extensions to macOS and so have made it harder to use it in Big Sur.

Kernel extensions allow developers a way to directly integrate with, and add features to, macOS and VirtualBox uses this method to add virtualisation feature to the macOS.

With macOS Big Sur, usage of third-party kernel extensions is diallowed by default. So before you use any software that needs kernel extensions (like VirtualBox) you need to explicitly instruct macOS to allow them.

The way to do this on macOS is to partially disable SIP. (Read more on how to disable SIP only on specific parts of the system.)

Thus, (as Rakib Fiha's answer suggests), even the VirtualBox Mac OS X build instructions advises the same - that you need to disable SIP for kernel extensions to allow macOS to load the VirtualBox kernel extension. And this needs to be done before installing VirtualBox.

To do this on macOS Big Sur, boot into Recovery mode, open Terminal and execute the following command:

$ csrutil enable --without kext

$ spctl kext-consent disable

Then restart and boot normally into macOS and download and install VirtualBox.

  • This did not work and is already a duplicate of what’s been suggested here. Commented Jan 8, 2021 at 9:40
  • 1
    Yes, it may seem like a duplicate but I had to post it as a new answer as the improvement edit I made to Rakib Fiha's answer was rejected (s/he uses the wrong terminology - like "enabling sip" when you are actually disabling it on some part). Anyway, your question seems to suggests that you totally reject needing to disable SIP to get VirtualBox to work. If you have tried it and it didn't work, what error did you actually get?
    – sfxedit
    Commented Jan 8, 2021 at 9:51

Here virtualbox is running on: BigSur 11.2 beta:

enter image description here

I had the exact same issue when I migrated from Catalina to BigSur. As mentioned in their official doc here , it is necessary to give MacOS permission to add custom kext.

So, you would need to enable SIP with kext signing by:

# needs to be executed in recovery mode
csrutil enable --without kext
spctl kext-consent disable

Also need to make sure that all the dependencies are installed before installing virtualbox.

sudo port install libidl acpica subversion doxygen texlive texlive-latex-extra texlive-fonts-extra x86_64-elf-gcc

If you disable SIP, please do it at your own precautions.

enter image description here

  • I don't want to build it, I just want to install it. Also, this does not address the fact that kernel extensions are no longer present in Big Sur. The documentation you link to does not address Big Sur, only up to Catalina, which still had kernel extensions just behind a manual approval process. Commented Jan 5, 2021 at 16:07
  • 1
    I see, what you are saying. But, I was having the exact same issue a few months ago on Big Sur in few of my VagrantBox in VirtualBox. After, I enabled SIP without kext It solved my problem. I also have debug and fs disabled for few other programs. But, I dont think those would be relevant to VirtualBox.
    – Rakib Fiha
    Commented Jan 5, 2021 at 16:09
  • This does not work as expected and in the end creates more work than to revert to Catalina from a backup. I had hoped to be able to skip that. Commented Jan 5, 2021 at 17:35
  • This is strange. If it works on my machine, it should be working in your machine as well. Are you using M1 or intel ? I am on Intel and using latest BigSur 11.2 beta uname -ar -> Darwin MacBookPro-4.local 20.3.0 Darwin Kernel Version 20.3.0: Mon Dec 7 22:04:02 PST 2020; root:xnu-7195. x86_64
    – Rakib Fiha
    Commented Jan 7, 2021 at 9:21
  • After upgrade to BigSur 11.4 in June, I've recovered both VirtualBox and MacFUSE (which also uses a Kernel extension) by means of csrutil disable + spctl kext-consent disable. My understanding is that BigSur still has kernel extensions, though in a deprecated state. macOS is becoming ever more rubbish.
    – zakmck
    Commented Jun 29, 2021 at 12:02

On macOS Monterey 12.4:

Download and run the current Virtual Box installer.

Open Virtual Box, and create a New (e.g. Win10) machine. At this stage, attempting to start it will cause a kernel driver (rc=-1908) error.

In MacOS System Preferences - Security & Privacy, click the lock (lower left) to fully enable the interface, then an option should appear to allow the Oracle software. (Supposedly this option can only be reached for 30min after the installation; otherwise will need to reinstall.)

In Virtual Box, attempting to start the machine, will be asked for an .iso installer boot image. This can be downloaded freely from Microsoft. (Click the folder when prompted, then click add, then navigate to the download..)

Make sure not to configure the guest box to use too much RAM, otherwise macOS will lock up and become non-responsive.

Note, an alternative is to use Boot Camp (included with macOS) to dual boot the host machine, likely with superior performance for gaming.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .