0

Background: Began working from home because pandemic. I have a 2014 Mini stuck at High Sierra as a main desktop at home. I brought home a MBP on High Sierra that sits on a shelf behind me, and I share the screen from it to the Mini using built-in Screen Sharing button in Finder. It's worked great since March.

Checkpoint VPN, which is mandatory for work, sent out a notice that clients below a given version would stop working on 1/1/21, and the new version required Big Sur. So I upgraded. Everything is fine, EXCEPT I can no longer connect to Screen Sharing on the Big Sur MBP from HS Mini (the other way works fine). How can I enable this again?

I've tried restarting the service. I tried changing who could connect, from all users to Admin only to specified users (me). Tried turning firewall off even though Screen Sharing was already allowed. Tried allowing Screen Sharing in Privacy options because Google turns up complaints of not being able to share screen in Zoom or Teams, and that was apparently the solution there but I don't have that same problem.

EDIT:

It turns out it's actually a Late 2014 Mini, and by searching the App Store, I found and upgraded to Big Sur. Still no joy with the "Share Screen" button in Finder, BUT... I just tried going to Screen Sharing > Connection > New, and put my Apple ID in, and got a popup on the laptop asking permission to share screen, and it worked! So it seems that only connect by hostname is impacted. Still no idea why, and it got me back to work, so I don't know how much more digging I'll do, but I'll leave this here in case it helps someone else work around the problem.

3
  • Did you try to access screen sharing before the VPN kicks in? – nohillside Jan 5 at 14:08
  • PS: A 2014 Mini should actually be upgradeable to Catalina – nohillside Jan 5 at 14:08
  • 1
    I did try before connecting to VPN. No difference. – Sammy Ominsky Jan 5 at 14:10

You must log in to answer this question.

Browse other questions tagged .