6

I've been having this problem for months, and I finally need help.

I found other topics on connection problems, but not quite the one I have.

When I'm at home I use a Wifi hotspot from my Android phone which has unlimited data, and my Macbook tends to disconnect quite often from this network, sometimes more often than others.

However my phone still has internet and other devices, like my playstation, can connect without problems.

Even more surprising, if do something that "continuously" uses internet, like Zoom calls, the Macbook almost never loses the connection.

Furthermore, when my Macbook disconnects, turning on the Playstation, also connected to the hotspot Wifi, seems to resolve the connection issue!

The Macbook has no problems to connect to any other Wifi network, like at work or at friend's places.

Do you have any clues on how to stabilise the connection of my Macbook when using the hotspot from my phone?

6
  • It may be that the hotspot disconnects automatically after sometime when it detects no network activity over the hotspot wifi. This could be to save battery. So check if you have some power saving mode or battery saver app that does this. When Wifi hotspot disconnects, macOS will try to connect to it or keep searching for others known wifi's to connect to.
    – sfxedit
    Commented Jan 3, 2021 at 18:41
  • Also check the tethering and mobile hotspot settings - Android 7 and above have a "timeout" setting which you set it to "never turn off".
    – sfxedit
    Commented Jan 3, 2021 at 18:46
  • Thank you for the answer! I checked and there are no power saving options activated. I cannot find any "timeout setting" in my phone, I can only choose a password, and Activate USB, Wifi or bluetooth sharing. Commented Jan 4, 2021 at 9:41
  • Please tell us the Android version you use?
    – sfxedit
    Commented Jan 5, 2021 at 18:33
  • It's Android 7.1.2 on a Fairphone 2 Thanks again for the help Commented Jan 7, 2021 at 8:15

2 Answers 2

0

A workaround I've found for the issue is to have something running in the background that continuously uses the network. For example, keep Spotify playing music.

0

'Renew DHCP lease' under wifi settings (the 'Details...' option) worked for me. This was really annoying. I spent a few minutes each day trying to implement suggestions from every forum. Finally, this worked. Hope this helps someone.enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .