1

I accidentally unplugged my hard drive without properly ejecting it, and now the drive does not mount when plugged in.

What can I do to make it work again?

I can see the disk in lsusb and diskutil list.

I've tried:

sudo diskutil unmountDisk force /dev/disk2

sudo diskutil unmount force /dev/disk2

I tried Run "First Aid" under Disk Utility getting this error message

enter image description here

Help me out from this issue. Thanks in advance

1
  • 1
    if this is an HFS+ disk try DiskWarrior. If it is APFS I think there is a 3rd party utility that might fix it but can't recall. Jan 2, 2021 at 17:27

2 Answers 2

2

The obvious cause is the filesystem or physical media can not make changes so make it reliable. Also, there are many different filesystem types and drives, so be sure your tool supports your OS and Hardware if you don’t try them for free first.

Do you have a backup? If not, do that immediately. You may need recovery software for this if the mechanism is failing. Disconnect the drive immediately if this is the case and buy a new drive that’s larger (or as large) as the drive so you can copy off the files before any more attempts to “fix” it. Sometimes the fix is deleting lost files or corrupt files to make the “filesystem” balance again.

If you want a third party tool to try and fix this, I use Disk Warrior first, then perhaps Drive Genius if I don’t want to just send it to the professionals.

If you don’t need to back up the data, just erase the drive entirely. That is free and Apple tools will test if the drive is functioning as part of the erase operation.

3
  • I have more than 1 TB of data in my hard disk drive. those are important files I don't have any other backups I need those files if erase I will be lost all of my data
    – Kishore
    Jan 2, 2021 at 17:56
  • @Kishore If that data is so important a second drive to always have a backup is cheap. I got a 4TB for 100 bucks the other week...
    – Solar Mike
    Jan 2, 2021 at 18:25
  • Good thing the system is warning you to back them up now before any more chance of loss @Kishore
    – bmike
    Jan 3, 2021 at 0:55
2

For this specific error, do the following-

  1. run Disk Utility/ First Aid a few times. There are cases where it may fix a bit of your partition map but still be unable to mount the partition containing your data, until run a few more times, this does look like a software rather than hardware issue
  2. If you're running a very new Operating System and the drive was prepared for an old operating system try doing this on an old machine
  3. AlSoft DiskWarrior is amazing at fixing this type of issue
  4. If that fails use a disk recovery utility or send out for recovery

Your key goal here is to get the data partition mounted so you can back it up. If you can do that, wipe the drive afterwards before putting your data back.

Please gain insight from this issue- if your data doesn't exist in 3 places, it doesn't exist.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .