Since about a week I have some icons in the Dock and in the Launchpad (e.g.: AppStore, Mission Control) with low-res icons.

Low-res App Store icon in Dock

However if I start the app (in this case App Store), the correct (high-res) icon is displayed:

High-res App Store icon in Dock if it is running

After quitting the application, the low-res icon will be displayed again.

I have the same symptoms for a handful of apps (mainly Apple applications).

What's the cause of this, and how can this be fixed to ensure high-res icons are shown?

  • I've had this same problem, but only with a couple apps from a few-year-old USB drive. Everything else works as expected. – Tuesday Feb 20 '12 at 20:58
  • I have the same problem and waiting for answer, only thing I have done different is updated iChat to new messenger – user19147 Feb 22 '12 at 20:12
  • 1
    Strange. Does the problem persist if you remove the app from the dock (by dragging it away from the Dock while the app is not running) and then add it again by launching the app, right-clicking its icon and selecting Keep in Dock)? – Dan J Feb 22 '12 at 21:23
  • To remove and add the app again to Dock reps. to Launchpad solves the problem, hoverer I have no clue what is the cause of it. – GeT Feb 23 '12 at 7:29

Cheekily adding this as an answer based on a comment above as the commenter didn't include it.

The cause appears to be a mystery, but if you remove the icon from the dock (just drag it away until you get the vanishing smoke animation), and re add the icon (run the app, right click on the dock icon and click Keep, or drag the icon back in from the finder) to get the full resolution icon for any app that is doing this. It's a workaround that doesn't explain the issue, but should be good enough.

  • 2
    I've just marked it as answer since this wo works. Nevertheless it would be interesting to found the root cause. – GeT Feb 28 '12 at 17:28

Try running a permissions repair from Disc Utility

  • 1
    Downvote?, really?, I had the same problem with my Quark icon in Lion, it was the only icon appearing lo res. I ran permissions repair, i used Titanium though, and it solved the problem. There are many icon images assigned to apps, some of which will appear lo res on a hi res screen, the finder should use the correct image for the re of the screen. This sometimes get corrupt, or confused, therefore a repair should do the trick. It is a much permanent solution to deleting the app from the dock and adding it again – Gav Ellis Feb 28 '12 at 15:06
  • 1
    Let's move some of that great comment into the answer - explaining why usually gets up votes. Also, this site is medium traffic so a few votes can initially sway things but over time, the good answers generally float to the top even if they dip at first. – bmike Feb 28 '12 at 15:34

just go to ~/library/cache and delete everything

restart the computer....

(always backup before)

you can also try this using a cache cleaner app such as http://www.macupdate.com/app/mac/9503/lion-cache-cleaner

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .