2

it seems a very similar problem has been reported. Nevertheless, its resolution is not clear and seems to be a matter of chance.

For clarity let me add the following background info:

For a couple of months I've been successfully running my 2013 iMac from an external SSD (for speed reasons). Initially, the SSD was a clone of my internal High Sierra Macintosh HD. Since then, program updates and content were added successfully to the SSD.

Today I performed a successful upgrade to Catalina. The system looked fine.

I then performed another recommended security + Safari update. When completed the Mac booted to the old High Sierra OS from the internal HDD!

I used the Startup preferences to set the external 10.15 OS X SSD as boot disk - no effect! still booting from HDD.

I tried rebooting into Recovery mode (cmd+R+power) to get access to the disk utility - no effect! the boot process form HDD continued regardless of that. This key combination worked fine when I cloned my HDD. The same happened when I tried NVRAM reset (opt+cmd+R+P) - the boot process form HDD continued regardless of that.

I disconnected the SSD and tried again Recovery mode and NVRAM reset. This time the key combination commands seem to work, but even though I selected to boot from the SSD, which I reconnected, iMac simply booted from the internal HDD.

I made the above attempts following advices provided in various forums where success was reported on sporadic cases.

Is there any structured procedure (or another wild idea), to set it right? i.e. make iMac boot from the external Catalina SSD

Comments:

  1. The external SSD is now displayed in Finder as two disks: Macintosh HD and Macintosh HD - data. This was probably created during the upgrade to Catalina. No idea why. (The internal HDD was never partitioned throughout all previous OS X upgrades).

  2. If worse comes to worst, I have a Time Machine backup of the SSD prior to the Catalina upgrade. Not sure how to use it under the circumstances.

Thanx

3
  • Have you tried: on startup hold option key. You should get a dialog to select a boot disk.
    – radarbob
    Commented Dec 30, 2020 at 22:20
  • could this help? - when booted into recovery mode - "Rather, go to the menu at the top of the screen, find "Utilities" and click on it. Select "Startup Security Utility" from that menu."
    – radarbob
    Commented Dec 30, 2020 at 22:26
  • I tried restarting + Opt key with the SSD connected - iMac ignored the pressed key and booted from HDD I further tried the same without the SSD - iMac got into a screen requesting to select a WiFi network and either to boot from the 10.13 HDD or from 10.13 Recovery image. I tried both options only to end with a frozen apple logo on screen. I then tried to restart (with SSD disconnected) + Cmd-R - I was able to get to the Startup Security Utility, but it only offered to protect my firmware with a password. I'm back to square one
    – AlonTAU
    Commented Dec 31, 2020 at 10:02

2 Answers 2

1

UPDATE

I found that I can boot from my external SSD reliably as long as my external HDD for Time Machine is not connected. No need for the extensive process below - just power down, unplug external HDD, and my Mac can boot from the external SSD.

---ORIGINAL POST BELOW---

I had the same issue and neither the SMC reset mentioned here or the NVRAM reset discussed here worked.

But the workaround I found to reliably boot off the SSD is:

  1. Power off the computer
  2. Disconnect the external SSD
  3. Power on the computer (which will boot off the internal hard drive's OS)
  4. Connect the external SSD
  5. Login and shut down
  6. Power on while holding the option key
  7. Select the external ssd from the menu and the computer will boot off the SSD
8
  • before the final resolution I described in my "good news answer" below, I tried your procedure as well, with no success. What is puzzling about all this is that slightly different procedures resolve the problem for different users.
    – AlonTAU
    Commented Jan 3, 2021 at 10:48
  • I have a hunch that problem might be with the "readiness" of the external SSD when the system tries to boot from it. If powering the SSD lags a few ms the system might mark it as "non relevant" and won't try booting from it again until SMC/NVRAM reset. A certain user in one of the forums I read mentioned that his resolution was hooking the SSD to a powered USB hub so maybe that way the SSD was already ON when the system accessed it for booting. I must say this theory is based on a wild educated guess :) Anyways, there is too much voodoo in this unfortunate phenomenon we all experience :(
    – AlonTAU
    Commented Jan 3, 2021 at 11:04
  • 1
    Yeah, this seems to be a really random issue. I just revised my answer because I found that if my external HDD for Time Machine isn't connected, my Mac boots fine - wonder if that applies to you as well?
    – user401101
    Commented Jan 4, 2021 at 2:09
  • For me, the restart after updating to Catalina went well and iMac booted from the external SSD. The problem started after the following SU 2020-001 update attempt. The restart after the SU update completion failed and the SSD was not recognized anymore. When finally achieved to boot from SSD, I realized that SU update wasn't completed. I never risked trying again the SU. Have you?
    – AlonTAU
    Commented Jan 5, 2021 at 10:22
  • Same for me re: initial update to Catalina - I'd done this weeks (months?) ago and didn't have a problem with booting until the 2020-001. But after being able to boot again into Catalina, I did run the update and it was fine - suspect it was because my external HDD was not attached, because that's been the cause of the problem for me it seems
    – user401101
    Commented Jan 6, 2021 at 15:58
0

Good news, after half an hour on phone with Apple's support, it works. For now.

The solution was SMC reset, which is: unplug all accessories, unplug from AC power for 15 sec., plug in again, wait 10 sec., and power up iMac.

I was astonished by this simple solution!

Few reservations though:

  1. Maybe the other steps I performed (such as NVRAM reset) also played an important role.

  2. Surprisingly, now that its back on, Catalina recommends to perform 2020-01 security update. I'm sure I did that before, and if I'm not wrong, the 'disaster' happened immediately afterwards. I'm avoiding it for the meantime. Apple Support said there is no known problem with it and I could try that in future.

  3. The SSD upgrade to Catalina seems to have affected the iMac operation when it booted to High Sierra from The HDD. I'm not sure how it will perform should I need to boot again from HDD. Maybe the SMC reset corrected that as well. Who knows...

  4. I'm still concerned if my iMac will continue to properly work from SSD for a prolonged period.

5
  • I’ve been doing it with a 2012 and 2013 iMac for 3 years (with a Samsung sata drive and sata to usb cable) before upgrading to a 2017 iMac and upgrading to a 1tb nvme ssd (external enclosure). No issues. Commented Jul 28, 2021 at 17:37
  • after extended practice i concluded that the problems i faced were associated with the number/type of devices connected to my iMac usb ports. anyway, if only the ssd is connected when iMac is restarting, all upgrade procedures work fine! thus, make sure you properly disconnect all other devices whenever reboot is required for any reason.
    – AlonTAU
    Commented Aug 11, 2021 at 7:02
  • I think your ssd draws a lot of power from a heavily used bus. Do you use the usb-A port or usb-c port on your Mac? I use the usb c port, and since it’s on a separate bus, it didn’t have power issues. However, I can imagine that a power-hungry ssd and a time machine backup disk, as well as something else (A phone charger has once disabled all my usb A buses because the total power usage was too high, but my ssd was still connected since it’s on usb c) can trip your usb off and prevent boot up or cause issues you say Commented Aug 11, 2021 at 12:31
  • basically, I had the iOS SSD + Time Machine HD + a Sandisk USB memory stick connected to the USB-A sockets on my iMac. In order to allow smooth reboot from my external SSD I had to disconnect BOTH the HD and USB memory prior to restarting.
    – AlonTAU
    Commented Apr 22, 2022 at 8:17
  • Now I use a USB 3 external hub for the HD and memo stick, and iMac restarts work fine! The hub is a powered type but the restart work well even when the hub is not hooked to mains. I'm not sure what caused the problem, but this workaround works :)
    – AlonTAU
    Commented Apr 22, 2022 at 8:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .