25

Equipment: Brother MFC-8890DW and Brother MFC-9320CW

I suspect it will work on: All older printers with Big Sur!

On upgrade to Big Sur, I found that my 8-year old expensive Brother MFC printers would no longer work, and that Apple was recommending that we use AirPrint. I could install the printers using macOS v10.15 (Catalina) (or older) drivers, and my scanners would work, but not the printers! AirPrint would not work either.

I scoured the web for many hours and tried 1) Resetting the printer system - no go. 2) Reinstalling CUPS (with SIP disabled and Gatekeeper disabled - no go because of Apple's read-only /usr filesystem ... not getting into setting up remounting the root (/) filesystem because of FileVault problems.

I noticed that this was a problem that everyone was having regardless of their printer brand - indicating that it was a system problem.

2
  • "Everyone was having this problem"? Apart from the HP certificate issue, I've not seen wide-spread reports of printer problems on Big Sur. My 14-year-old HP 5200 works fine, and CUPS is broadly identical to Catalina. – benwiggy Jan 1 at 10:37
  • I have the MFC-9320CW, works fine now. I reset the printer system, then rebooted. For me it didn't show the scanner (Image Capture app). So it should work! – Roger Jan 6 at 8:58
33

What worked: I read the error logs on my printers. They pointed me to permission problems with /usr/libexec/cups. Perms should be 755.

To make this work:

  • System Integrity Protection should be disabled.
  • You must be a sudoer or have root permissions.

Instructions

Open a terminal.

  • cd to /usr/libexec
  • sudo chmod -R 755 cups

That's it! Printing with older drivers works now! AirPrint works. The scanners work. Apparently Apple screwed up the perms on the cups directory that makes printing work when they created their protected filesystem! Urrgghh! This should work with all older printers regardless of brand.

YMMV.

14
  • Thanks for putting a proper answer in! I know it’s a pain to accept later, but it does really help people out and you can always award the answer to someone else if another better answer arrives later. – bmike Dec 30 '20 at 19:58
  • No problem. Just learning the ropes! – wkumito Dec 30 '20 at 20:13
  • Can you re-enable System Integrity Protection afterward, or must it remain disabled for your changes to stay intact? – Eptin Dec 31 '20 at 4:39
  • Good question. I haven't tried re-enabling yet. – wkumito Dec 31 '20 at 6:22
  • 3
    This shouldn't be the bleeding edge., This is a public release, not a beta. I love Apple, but after using their products for decades, and not finding a better alternative I cut them some slack. Sometimes a release is not quite up to par. This is a pattern for Apple from time to time. As long as they don't do this too frequently. Given that Big Sur was released concurrently with the M1, I think it is great. It just needs better QC. Time for a bug fix release, Tim Cook – wkumito Jan 1 at 7:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .