Since the previous update (the one before BigSur), my system preferences were terrible slow. Since the update to BigSur, the systempref's stopped working at all.

The error says: "Preferences error The 'x' preference pane cannot be loaded"

enter image description here

This happens on all preference panes, here is a video explaining the problem.

I've tried

  • SMC reset (putting off, disconnecting cable for a while, reconnecting and restarting)
  • PRAM + NVRAM reset (shut down, hold option, cmd + P + R)
  • Deleted the systemprefs .plist file and restarted

Nothing worked so far, I can't connect my bluetooth mouse, headphones, and all the other settings. Can some one help me out with this issue?

-Update- Okay, I guess I somehow found the error... I logged in to the new account again. And look at this... https://youtu.be/kapOvWY8xXE

When I go to the apple icon in the top left corner, it gives me another version of systemprefs. When I go to the systemprefs trough the applicationsfolder, I've got the 'new' systemprefs witch works as it should... The question now is, how can I override the 'old' systemprefs with the 'new' in the top-menu.

  • If you create a new user account on your Mac, can you open System Preferences there?
    – nohillside
    Dec 30, 2020 at 12:34
  • Thanks @nohillside for your response. I've made a new user (trough terminal), but it has the same problem.
    – HugOnline
    Dec 30, 2020 at 14:32
  • User-supplied preference panes can be found in /Library/PreferencePanes/ and ~/Library/PreferencePanes/. As the problem seems to be system-wide, start by temporarily moving all folders in /Library/PreferencePanes/ to another place and try again.
    – nohillside
    Dec 30, 2020 at 14:59
  • Also, please have a look at /var/log/system.log at a point in time you tried to access preference panes, maybe it gives a clue. I somehow suspect access right/permission issues
    – nohillside
    Dec 30, 2020 at 15:02
  • @nohillside Hmm, both folders are empty... maby thats the issue? Let me take a look at the log. Thanks for your help so far! :)
    – HugOnline
    Dec 30, 2020 at 15:47

1 Answer 1


Yes. I like to make a new user account and the log out of all the old users. No data is lost, but you can time the new user to open preferences.

Then you know if the problem is the system needs to be fixed / reinstalled or just your user has corrupt preferences.

Assuming it’s not your user account, this might be faster to sort by a Time Machine backup and erasing the mac to reinstall a clean OS. Once you’re sure it’s not a bug in a clean OS, you can run Migration Assistant and bring back your apps / documents and not your settings in the hopes that it cures the issue.

Sorry I don’t have a more surgical method to isolate this reliably. It’s hitting what might be an isolated issue with a big hammer, but you probably need a backup anyhow since the system is degrading and you’ll likely spend more time troubleshooting this than testing a clean install.

  • Thanks @Bmike for your response. I've made a new user (trough terminal), but it has the same problem.
    – HugOnline
    Dec 30, 2020 at 14:32
  • @HugOnline Wonderful isolation - I’ll expand on my answer - my solution isn’t a great one - hopefully someone more skilled or with time to reproduce it could propose a more precise fix.
    – bmike
    Dec 30, 2020 at 15:19
  • Thanks for the help and update @bmike. As u can see, I've updated the question, you can see there I somehow found a solution!
    – HugOnline
    Dec 31, 2020 at 11:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .