1

I recently got a new MacBook Pro for work/personal usage, the physical keyboard itself has a default US English qwerty layout. In keyboard settings I added ABC and Hungarian. It works perfectly, except for one little thing when I change to Hungarian input there is no way to write 0.

Is there a key combination, or way to configure it? It's very frustrating whenever I write something in Hungarian and have to change the input source back to ABC just to write 0.

3
  • 1
    Try control option zero – Tom Gewecke Dec 29 '20 at 14:13
  • Thank you @TomGewecke. This option why not shown by the on-screen keyboard? – Syngularity Dec 29 '20 at 14:18
  • No idea. It may not work with all apps, not sure. Hungarian qwerty has it at option ` . – Tom Gewecke Dec 29 '20 at 14:58
1

Hungary (and the rest of Europe) uses the ISO keyboard, which has one extra key compared to the US Qwerty keyboard. As a result, some characters may go missing or be misplaced when you try to use European layouts with the US keyboard.

Hungarian Qwerty has the zero at Option `. Hungarian (which is qwertz) seems to have it at Control Option Zero. (Mac's don't normally use Control for characters like this, so it may not work in all apps.)

You can also create a custom layout, or set up a text shortcut in system preferences > keyboard > text > replace with.

ABC Extended has zero in the normal place and can make all the Hungarian special characters via option dead keys.

https://sites.psu.edu/symbolcodes/mac/codemacext/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .