I am trying to install OS X Yosemite on a dedicated partition of a MBP 13" mid 2012 running Catalina (I need dual boot).

I downloaded the file from the official Apple page and followed these instructions to get the .app file and, using createinstallmedia, I created a bootable installer on the new "Yosemite" partition.

I then booted my Mac choosing the Yosemite partition mentioned above and started the installation, however I got the error message mentioned here and here. I see that most of the users fixed the problem by changing the system date, I have tried many different dates but I always get same error message. I have also re-downloaded the file, but by checking with diff it seems identical to the first I downloaded.

The hdiutil verify method proposed here generates a "valid" output.

Is there anything else I could try?


1 Answer 1


This is not so much a definitive answer as some speculation based on prior known behaviour.

One thing to note is that the 'date/certificate issue' should now be fixed for all older installers & so shouldn't need any workaround in that respect.

I haven't tried any of these older installers in a while, but in the past some were only valid if your computer could not run any newer OS. The El Capitan installer was specifically 'sold' that way.
The Apple site you linked also obliquely points in the same direction. Each of those links says "can upgrade…" (I don't have any recent hard evidence to know if this is true or not).
See How can I download an older version of OS X/macOS? for some history behind this, though the answer is probably falling behind the times now. I can't maintain it any more as I have no Mac capable of running anything newer than Mojave.

On a Mac Pro I'd test this by removing the drive with Catalina on it & installing from USB to a fresh clean drive. Not sure that's so easy on a laptop.

One thing I would definitely try… You appear to be creating the installer on the same partition you want to install to (if I'm reading you correctly). I'm pretty sure this isn't going to work. Create the installer on a separate USB stick & boot to that, then attempt install to the internal partition.

Alternatively, you could try installing from Internet Recovery. If you boot holding Cmd ⌘ Opt ⌥ Shift ⇧ R the installer presented should be the one that originally shipped with your Mac. If that's successful, then the earlier potential caveat of 'can update from' would then be on your side.

One other thing to note is that as these installers are all designed "to update" then I'd be pretty sure they will run as an app if mounted to a Mac already running any OS older than the installer. It wouldn't need to be made into a USB boot drive. That would make your upgrade from your original OS over Internet Recovery much simpler… maybe ;)

From comments
Apparently the new installer dmg files install the "Install macOS (name)" into your apps folder, from where you can run the update.

  • Thanks for all the information! I will go through all your points. I have never tried the Cmd + Opt +Shift +R combination and maybe that's a good start. Does such installer allow me to choose the partition I want to install the "original shipped" OS or am I forced to install it on the main partition (the one running Catalina now)?
    – Eugenio
    Dec 29, 2020 at 14:19
  • You should be able to choose a partition. Yosemite won't be able to read the Catalina partition anyway, as it's APFS, so it would default to the remaining one it can see - the HFS+ btw, I wouldn't do any of this without a known good backup in place.
    – Tetsujin
    Dec 29, 2020 at 14:22
  • I was able to install OS X Mountain Lion on the desired partition using the Cmd + Opt +Shift +R combination; later I rebooted on Catalina and launched the Yosemite installation (that should be a "normal" upgrade now); however, when the installer shows me the various destinations partitions, the one containing the Yosemite installation has a yellow warning sign and a generic message "It's impossible to install OS X on this disk" (I am translating from Italian, it might be different) so I can't choose it.
    – Eugenio
    Dec 29, 2020 at 18:54
  • 1
    Update: I've tried to launch the upgrade procedure from Mountain Lion (and not from Catalina) and it worked! Thanks a lot! Just a note for anybody who might read this: running the installer just generate the installation app in the app folder, which is what you need to launch afterwards, this might be not super obvious because the procedure did not mention that.
    – Eugenio
    Dec 29, 2020 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .