I have the following problem. I wanted to have dual boot to Ubuntu, so I've created 3 additional partitions using BootCamp (I probably created freespace with Bootcamp and then used Ubuntu installer to partition the free space, I cannot remember exactly, since this was 2 years ago). Now I want to remove these partitions to reclaim space, but the only thing I can is to reformat them to use MacOsX HPFS+. I tried booting from the Mac Os X install CD, but that did not help. When I try to remove partition by pressing - in Disk Utility it just throws some error about MediaKit. The only thing I am allowed to do is to reformat the disk entirely.

I've searched this site and in some answers I've found that you cannot change partition table on hard drives with MBR (i.e. if you have a mac os x boot on one partition, you cannot change the partition table). Is this really the case? Seems like a huge restriction on Apple's part.

Or is it that bootcamp (or ubuntu installer) has written wrong partition table, and now there is no way to change it?

I'm using udpated Snow Leopard.

Here is the output of diskutil:

ivrin:gdpp mpiktas$ diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            195.3 GB   disk0s2
   3:                  Apple_HFS disk0s3                 11.9 GB    disk0s3
   4:                  Apple_HFS Linux Swap              4.2 GB     disk0s4
   5:                  Apple_HFS freespace               38.0 GB    disk0s5

You should be able to repartition uour HDD using Disk Utility (see this related question). You should also be able to remove the BootCamp partition using the Boot Camp Assistant.

  • I do not have any additional partitions installed as in your given link. I've added the output in diskutil. – mpiktas Feb 20 '12 at 8:50
  • @mpiktas - What exact error is being thrown? Did you try using the Boot Camp Assistant to revert to one partition? You could try to erase and merge disk0s3 and the rest into disk0s2 but this might result in data loss on disk0s2 (if it's not HFS+ or if you use force). – Vlad Feb 20 '12 at 9:17
  • Ok, now it works. I've managed to remove the partition. Bizarre. – mpiktas Feb 20 '12 at 10:13
  • @mpiktas Please consider marking this answer as accepted, or posting your own answer for what you did that worked and marking it as accepted so future visitors know what exactly helped you. – Adam Davis Mar 23 '12 at 18:58

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .