2

I connected my cannon Vixia HF R70 Camera to my mac. I am running Mac OS 10.15.7 (Catalina on a Mac Book Air)

It is a standard USB A connector cable. I was prompted with a window on what I want to do, and one of the options was "Do not ever ask what to do/do nothing". By mistake I clicked that, and now whenever I connect my camera it does not show.

Things I have done to try fixing: Have tried different USB ports, rebooting. Ensuring my finder is configured to display all external drives and devices

I have gone into About My Mac -> System Report -> USB Devices Inside of this I DO see my Cannon camera.

Thus, whenever I connect the computer recognizes it but does not show it.

Can somebody help advise please? Thank you.

1

Open the Image Capture app and select the camera. You can manually import images or change the settings. This app manages the cameras and bulk image import from storage media for macOS Catalina and lower.

3
  • Perfect, thank you. This works! Can't upvote because I am new but appreciate the help. – user7841016 Dec 28 '20 at 0:48
  • Wonderful. The check mark to indicate you have an answer helps the most people. Do t worry about voting till you’re here a while. So glad it was what you needed. – bmike Dec 28 '20 at 13:25
  • 1
    Got it, thanks for that tip, have marked the check mark. – user7841016 Dec 29 '20 at 16:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .