0

I am trying to transfer some christmas photos from my iPhone to my Mac via airdrop but after the photos are downloaded on my Mac, around 80% of them are transferring as damaged or corrupt files and unable to be opened with any application (I tried different programs).

Its a new iPhone 12 and all the best quality photos (particularly the portrait mode ones) are crashing, whereas videos are fine.

I'm not able to connect it with a manual cable to use Photos or iTunes because the 12 has the new cable which doesn't fit into my Macbook air. I can't wirelessly sync it to iTunes either as the sync option is just greyed out.

If anyone has any advice on how to refresh airdrop, Mac or the phone so that it transfers the photos smoothly it would be great help.

Thank you and happy holidays!

5
  • Welcome to AD. Have a look at the Tour: apple.stackexchange.com/tour Can you tell us what exact programs you tried to open the files? Can you tell us the specific Mac model and installed version of macOS? Further, if you click on the share icon on iOS and then hit options, do you have all data ticked? And further, the only app as far as I know that handles iPhone photos with portrait mode and such very well is Apples own Photos app, so you might want to try to import them there (preferably via cable). – X_841 Dec 27 '20 at 11:04
  • In addition to the above comment, I wonder if the iPhone is shooting the photos as HEIF and your Mac can't read the files? If so, you can change the Camera's settings in iOS settings and change the formate to Most Compatible instead of High Efficiency. I don't think this will convert your Christmas photos, but it would take affect for future photos – AVelj Dec 27 '20 at 11:24
  • @X_841 The program (by default) is Preview, and I've also tried ColourSyncUtility, Google Chrome and Safari. The Mac model is a MacBook Air from 2017 with version 10.13.3. I didn't have all data ticked, however I tried it again and the issue is the same - the photo arrives on my Mac, and then is unable to be opened. I tried via the Photos app also with a cable, but Photos responds to the photo with "Cannot import: Unable to read metadata" – Rida Dec 28 '20 at 23:02
  • @AVelj It was on high efficiency, so I have changed it and took new photos to test it out with the Most Compatible setting, but no difference. – Rida Dec 28 '20 at 23:02
  • if you can, I would advise you to update your macOS version, since 10.13 may soon not get any security updates and also might cause these intercompatability issues – X_841 Dec 29 '20 at 14:59

You must log in to answer this question.

Browse other questions tagged .