I booted up my MacBook Air (running Mac OS X Lion) and the desktop doesn't have a menubar. I used option+right-click to relaunch Finder and there isn't an option to relaunch it. When I launch an application the menubar shows up. When I cmd+q to quit the application the application's window closes but the menubar then defaults to the last currently open application. Even if it's on a different virtual desktop.

When I reboot the computer I notice that the keyboard is no longer backlit by default. The keyboard only becomes backlit after I correctly enter my password. I don't know if this is related to the problem stated in the first paragraph. It may or may not be relevant. I don't know.

Any thoughts or ideas? I've never seen a desktop in Mac OS X that didn't have a menubar.

To recap: No menubar, no date, time, Spotlight icon etc. when all applications are closed. They show up when I launch an application. Option to relaunch Finder is gone.

  • I've seen this recently. I don't know how to resolve it any other way than restarting sometimes more than once.
    – EmmEff
    Commented Feb 20, 2012 at 3:03
  • Well, I've rebooted about 10 times now and to no avail. I created a new user and the problem exists for the new user.
    – user7787
    Commented Feb 20, 2012 at 4:34
  • 2
    try restarting the process called "System UI Server" (or something like that with an _ i think_)
    – Alexander
    Commented Feb 20, 2012 at 5:22
  • When this happens, does a Finder process appear in Activity Monitor, or (via Terminal) in ps waux | grep Finder?
    – bneely
    Commented Feb 20, 2012 at 5:26
  • @XAleXOwnZX: +1 for SystemUIServer. This is the process that encompasses the Spotlight, Clock, etc. process icons. Killing that in Activity Monitor will cause it to restart automatically.
    – binarybob
    Commented Feb 20, 2012 at 9:27

3 Answers 3


Try quitting Finder using Activity Monitor (in Utilities). It's in Launchpad there too. Scroll down the list of processes till you see Finder, click it and then choose Quit Process from the toolbar. Choose "Force Quit" at the dialog.

If Finder isn't in the list of applications in Activity Monitor, you can manually start it. It's located at /System/Library/CoreServices/Finder.app. If you can't get to it by browsing (because Finder isn't running!) you can always use Terminal. It's in Utilities too. Just type

open /System/Library/CoreServices/Finder.app

into the window and hit return.

  • I did this and the problem persists. There is no menubar when all applications are closed. When I open a folder (getting a Finder window) the menubar still doesn't show. There is no option to relaunch Finder when I option+right-click the Finder icon from the Dock.
    – user7787
    Commented Feb 20, 2012 at 11:45
  • 2
    Sounds like the problem described at discussions.apple.com/message/17644065 it's possible you've got something nefarious installed by 3rd party software too.
    – Cathy
    Commented Feb 20, 2012 at 22:19
  • That's me! I'm going to reinstall the operating system. Thanks for your help.
    – user7787
    Commented Feb 21, 2012 at 0:49

try restarting the process called "SystemUIServer" and post what happens as a comment to this answer. I'll update my answer with any possible insight i can give.

  • I've restarted SystemUIServer. Nothing happened. It just started again right away with a new process id. I've killed Finder too with the same result. I've booted in safe mode. Same problem but now the keyboard is backlit at the login screen. I've created a new user and the new user experiences the same problem. When no applications are running there is no menubar.
    – user7787
    Commented Feb 20, 2012 at 17:31
  • i've never heard of that before =/ that's unfortunate. I think reinstalling lion would be the easiest way to fix it
    – Alexander
    Commented Feb 20, 2012 at 18:30
  • Yeah, I think I'm going to have to do this.
    – user7787
    Commented Feb 20, 2012 at 18:33
  • i'm looking into a way of clearing the gunk clogging up systemUIServer but i can only use AppZapper to do it if it's closed, which is tough since its autolaunched by launchd
    – Alexander
    Commented Feb 20, 2012 at 18:46

I know a really easy way to fix this(if you have an Apple TV). Go to someone else's laptop and duplicate finder and put on a USB flash drive. Put the flash drive in your computer and turn on the Apple TV and aim and press the button on the remote at your computer (iTunes should open up). In iTunes, go to the Apple icon in the top left corner and open System Preferences. Go to accounts and press the plus sign next to the minus sign. Something should come up that has your USB drive on the sidebar. Go to your flash drive drive, select Finder and click "add".

Once you have done that, select Finder in the list of things to open up once you log in. Log out of your account and log back in. If you do not know your password, try leaving it blank.

Notice: Use Finder from a laptop with the same version as yours.

You must log in to answer this question.