0

At least once a day it seems that my Git global configuration value for user.name gets reset to a blank value. Of course I only find out when I go to commit and it barks at me. I've tried removing and readding, replacing all matching keys. Here are the following specs/configs I would think are relevant:

  • MacBook Pro 15,1 (2018)
  • macOS 11.1
  • iTerm2 v3.4.3
  • Git v2.24.3 (Apple Git-128)

I also have Oh My Zsh installed, master commit SHA b28665a.

4
  • Where have you set the username?
    – mmmmmm
    Jan 17 at 9:44
  • I had set the user.name and user.email with the command and --global flag. I also had configured those properties per project as well, but all projects would eventually (and daily) ignore the local and global settings. I also tried using the --system flag when setting it, but that wasn't the fix. Jan 18 at 17:59
  • What was the command?
    – mmmmmm
    Jan 18 at 19:19
  • git config --global user.name "<name>" Jan 19 at 0:49
1

I managed to fix this by manually removing the entry for "credential.helper=osxkeychain" in my global config file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .