2

I tried to change the settings to all sorts of scenarios, but the laptop just refuses to hibernate right away. I want it to bypass sleep/standby completely, and cut off power to RAM immediately (hibernate).

I tried setting sleepdelayhigh/low and autopoweroffdelay to 0, with standby and autopoweroff to 0. Didn't work.

Then I changed standby and autopoweroff to 1, but with 0 delay seconds. Again, didn't work.

Then I decided to change the delay to 60s. Didn't work.

I also experimented with hibernate 3 and 25.

It goes into hibernate after about 1 hour and I don't understand why it stays in sleep mode for so long.

Another problem that I have is I setup displaysleep to 5 mins with auto sleep to 30mins, but every time the display is switched off, it goes immediately to sleep. Insane! I had to go back to 15mins.

This is what I have right now, but like I said, it just doesn't hibernate after 60s. Neither on battery nor on AC.

 standbydelaylow      60
 standby              1
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 powernap             0
 gpuswitch            2
 disksleep            10
 standbydelayhigh     60
 sleep                15
 autopoweroffdelay    60
 hibernatemode        25
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         15
 highstandbythreshold 50
 acwake               0
 lidwake              1
 

1 Answer 1

0

These settings worked for me on my MacMini 2018

$ pmset -g
System-wide power settings:
Currently in use:
 standby              1
 Sleep On Power Button 1
 womp                 0
 autorestart          0
 hibernatefile        /var/vm/sleepimage
 proximitywake        1
 powernap             0
 gpuswitch            2
 networkoversleep     0
 disksleep            0
 standbydelayhigh     1
 sleep                0
 hibernatemode        25
 ttyskeepawake        1
 displaysleep         0 (display sleep prevented by Vivaldi)
 tcpkeepalive         1
 highstandbythreshold 50
 standbydelaylow      1
2
  • Sleep management on a Mini may be different from a laptop.
    – benwiggy
    Jul 7, 2021 at 9:06
  • @benwiggy Fair point. I have a laptop, MacMini, and an iMac. All BigSur. I just checked them all. They behave the same.
    – cartland
    Jul 11, 2021 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .