0

I broke my Time Machine backup by using tmutil delete on the most recent backup. This meant that the "Latest" symlink no longer pointed to a valid location. My attempts to create a replacement symlink have failed, probably due to some sort ACL issue or a problem with extended attributes.

Here is an attempt to recreate the symbolic link:

DeepThought:DeepThought cclark$ sudo ln -sn ./2020-12-20-161820 Latest
Password:
ln: Latest: Operation not permitted

Has anyone ever recovered from this situation?

I have tried disabling SIP, and have made sure that Terminal has been granted Full Disk access. I have also tried creating an alias using Finder, which was successful but was not recognized by Time Machine.

The backup is on a Synology NAS.

1
  • Can you not just do another backup? I would assume that should fix the symlink.
    – At0mic
    Dec 25 '20 at 15:16
1

The problem eventually worked itself out. I think that choosing to verify the backup may have helped.

1
  • This is a case where it’s hard to pin down cause and effect from correlation. Glad that with patience it fixed itself
    – bmike
    Jan 20 at 23:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .