1

I'm on macOS Big Sur 11.1, and I wanted to use a different folder for my Safari downloads, so I created another directory and did ln -s ~/Downloads on it (symlinked). Everything works fine except for a small thing.

In the Finder app, on the sidebar, this folder has a "standard folder" icon, even if it is recognized in the preferences as my Downloads folder (see the attached pictures).

Is there any way to at least make the Finder think that folder as the original Downloads folder?

Or maybe is there a way to manually change its icon?

Please note that I already found some answers to my question on this site, but they seem to not to be compatible with Big Sur.

Sidebar

Finder Preferences

1
  • I think the symbolic link to another folder is causing the problem with the icon. The finder side bar is recognizing that the target is just a regular folder not the real original downloads folder. Do a web search for how to add an icon to a regular folder, and do that to your new folder. Make sure that you can see that icon just in a regular finder folder window. After that you might need to restart the finder or your Mac to see the correct icon in your sidebar. – jimtut Apr 14 at 1:34
0

From what I've understood, this is what I could come up with. As useless as this may sound, have you tried unchecking and re-checking the box that enables Downloads in the sidebar? Also, you can try going to the parent directory of the Downloads folder, right-clicking the Downloads folder, and then clicking "Get Info" to see if the Download icon is there for the Downloads folder. If there isn't then you need to get the icon from somewhere and then drag it onto the existing icon in the "Get Info" window. Hope this helps!

1
  • Unfortunately I already checked/unchecked the box that you say and it didn't work, also I already set the folder icon to the one of the original downloads folder. – DavideR Dec 21 '20 at 10:26
0

Have you tried to uncheck the Downloads folder in the Finder Preferences and just drag the symlinked folder to the sidebar?

1
  • Yes I already did unfortunately. – DavideR Jan 23 at 10:24
0

I had this same issue. Everything was checked in Finder Preferences and it drove me nuts. Turned out that in the top left of the sidebar where it says 'Favorites' there is an arrow to the right '>' Once I clicked that, it dropped the folders down into view. press arrow to the right of 'favorites' in side bar

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .