0

iPhone SE (gen 1). Prior to updating my iOS from 13.x to 14.x I was successfully using Personal Hotspot to connect my laptop to the internet using Lightning-USB cable. Then I updated my iOS to 14.x (can't quite remember the exact version), everything was fine for some time. And then all of a sudden my internet connection just dropped and never came back up again. I still have this blue bar indicating the connection on the top and my laptop indicates the connection, yet no internet connection.

I tried:

  1. Rebooting my device
  2. Resetting my Network Settings
  3. Updating my iOS 14.x to 14.3
  4. Connecting to another USB port
  5. Connecting my iPhone to another laptop

None of the above worked, all the same.

However, using Wi-Fi Hotspot instead of direct USB connection works perfectly fine but it's not an option for me.

I also tried connecting through my second iPhone's Personal Hotspot (iPhone 8, iOS 14.3), same effect, it works over Wi-Fi, doesn't work over direct USB connection.

Any thoughts? I appreciate any help.

UPDATE

As of Dec 25th 2020 this issue is now Linux-specific only. I was able to connect via USB on Windows laptop after some painful acts of update. Force-(re)updated iOS via latest version of iTunes.

1 Answer 1

1

Welcome to Ask Different. Is your Laptop a Mac or a PC?

If it's a Mac, you might want to check if the USB connection has not been made inactive/lower service order in Network Settings within System Preferences on the Mac.

To check, go to System Preferences>Network; on the left you will see a list of connections (e.g. Wifi, Bluetooth, Ethernet, iPhone USB, etc.). If you see a green dot on those connections, it means you are connected to them.

If iPhone USB is showing as not connected, check if "Disable unless needed" has been enabled, and disable it if it is. Furthermore, if you have multiple successful connections, it is possible the service order prioritises the other connections over your USB connection. So at the bottom of that list, click on more options icon and select Set service order, now you should be able to reorder the connections priority to prioritise iPhone USB above wifi, ethernet, etc.

enter image description here

Finally, you mentioned you have reset network settings. Did you do this on your iPhone or on your laptop?

Sometimes the trust relationship between the Laptop and iPhone can be corrupted or need a reset after updating. You can reset this trust relationship in iOS settings, by going to Settings>General>Reset>Reset Location & Privacy. After resetting location and privacy settings, the iPhone will prompt you to trust the device it is connecting to. Trusting the device (laptop) will rewrite the trust relationship between the two devices.

Note, resetting location and privacy settings will prompt you to trust every other device your iPhone connects to. This should only happen on the initial connection to that device after you have reset these settings.

Let me know how you go. Best of luck!

1
  • Thank you for your answer. As mentioned previously, it is marked as connected on both sides, I'm connected to the device, not the internet, it won't open any page. My laptop is not running MacOS, I've tried two laptops, first one running Linux, second one running Windows, either one failed to provide the internet access over USB. Most likely, it has nothing to do with the laptop. Resetting Location & Privacy didn't help either.
    – Dei
    Commented Dec 20, 2020 at 19:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .