0

I bought a 4K Dell P2721Q monitor and connected it to my old late 2013 MacBook Pro 15" via a Mini DisplayPort to DisplayPort cable. It connected without problems and shows that I have 4K resolution and 60Hz refresh rate.

When I tried to play 4K video on YouTube in Chrome, it was constantly showing a "loading" indicator. I thought it was problem with my Internet, but playing the same video in 4K on the MacBook display works fine and smooth.

Then I tried playing 4K YouTube video from Safari, it was definitely better than in Chrome, but it was still choppy. Doing some other activities like browsing/scrolling tall websites seems to work OK, there is are no lags.

What could be potential problems to investigate? Is this possible due to bad cable (I bought one in the mid price range, it has clear 4K 60hz marking on it and there are user reviews which claim it worked fine for them)? I noticed that after several minutes of playback CPU temp rises above 80 degrees up to 90 and then returns back below 80 (fans start to work louder). Could it be due to some CPU throttling?

Anything else I should try to check?

Macbook details:
MacBook Pro (Retina, 15-inch, Late 2013), 2.3 GHz Quad-Core Intel Core i7, 16 GB 1600 MHz DDR3, NVIDIA GeForce GT 750M 2 GB, Intel Iris Pro 1536 MB

4
  • 1
    Please provide the exact Mac model. Most of the (many) 2013 models can't run 4k graphics. Those that can are only capable of 30Hz at your Dell's max resolution of 3840x2160. That aside, the fact that the GPU can barely drive the screen at all should be a hint as to why it it going to really struggle decoding 4k video.
    – Tetsujin
    Dec 19 '20 at 11:16
  • @Tetsujin I edited post to include details. As I said I am able to get 60hz without any manipulations at all, it just worked. And I researched beforehand a lot of people claimed that they managed to make it work. I have dedicated GeForce GPU which in theory should take care of external monitor.
    – Aleksey
    Dec 19 '20 at 11:32
  • 1
    Everymac says 30Hz max over HDMI, not at all over TB. everymac.com/systems/apple/macbook_pro/specs/… Anyway, I still think the issue is trying to get an old 750M driving & decoding 4k. I doubt on a card of that age that the GPU will be helping out the decode, it will all be in CPU, with the GPU just trying to keep up to the refresh rate.
    – Tetsujin
    Dec 19 '20 at 11:38
  • As I described I connected via display port not via HDMI. But I guess you right I am expecting a bit too much from 7 year old laptop.
    – Aleksey
    Dec 19 '20 at 12:01
2

It's about the decoding codec. Chrome does not support hardware accelerated vp9 codec on Mac OS, which is required to decode any 4k video on Youtube. Which means when decoding the 4k video it's using your CPU's resource instead of the GPU. Good luck trying to decode any 4k video using a mobile CPU, it simply won't work, a 9900k might do it, but a mobile chip, nope. For safari it should support hardware VP9 decoding, however, your Macbook is so old I highly suspect that the GPU does not support VP9 decoding. Anyway my Macbook Air 2020 has difficulty running 4k on Chrome, and always drops frame during the first few seconds of full screen on a 4k external monitor when using Safari. Time to buy a new laptop if you want smooth 4k video experience.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .