1

I had my previous Mac Mini configured where /Users was a link to a separate volume on my dual disk system. I tried upgrading to Catalina on that machine and discovered that this link caused the upgrade to fail (and there didn't seem to be a clean downgrade path), so I finally got around to transitioning to my new Mac Mini which has a much larger boot drive and all would be well.

Except it turns out that my time machine backups respected the sym link and when I recovered, I see a symlink to a non-existent drive in my root directory. I figure I can still somewhat easily recover the files from the old machine over the network, but I need to rebuild /Users. When I try to delete or rename the symlink, I get a message, Operation not permitted. How do I re-create my Users directory short of doing a clean install which I'd prefer to avoid if possible?

Update The new machine has Catalina Mojave (probably from the backup restore) on it. I tried giving Terminal whole disk access, but the process gets hung on the authorization step, I suspect because I don't have a viable Users directory. I've been able to get the old Mac Mini into a bootable state with Mojave running on it so my next step will be to try to get the new Mac Mini connected with target disk mode (assuming I can find the TB 2 cable which I thought I had on my desk).

Update 2 I didn't have a TB2 cable, I had a Firewire 800 cable. I've ended up reinstalling MacOS de novo on the new machine and I'm doing a migration from the old machine using migration assistant and an ethernet cable to connect them both. I don't know that there is any other possible solution to the problem. MacOS really doesn't like having the Users directory symlinked to another volume.

1
  • Which version of macOS is the new Mini running? – nohillside Dec 19 '20 at 8:43

You must log in to answer this question.

Browse other questions tagged .