0

I'm trying to remove JAMF completely from a MacBook Pro M1 and actually start afresh. I can successfully put it into DFU mode in Apple Configurator 2, and I've tried both Revive and Restore, but what happens each time is that when the MBP reboots after the operation, there are some setup screens and then I'm taken to a screen that forces auto-configuration with a JAMF server!

What am I doing wrong?

3

Your Apple serial number is integrated with Apple Business manager and JAMF server configuration. Unless, the ABM manger remove/release your serial number, you will keep on getting JAMF setup configuration.

In other hand, you can skip auto-configuration of JAMF setup without being in Internet when you reboot your MBP after you revive and restore as you mentioned in your question.

Also, I would suggest

  • Reset the Login Keychain
  • Remove any instances of the MDM CA in the keychain
  • Open terminal and ran "sudo jamf removeFramework"
  • Remove all related MDM preferences in /Library/Preferences
  • Remove all related MDM preferences in /Users/username/Library/Preferences
  • Reboot

However, Note: It's only possible if your JAMF admin has allowed an option to remove MDM Profile.

Else, only one last option is to reach out JAMF administrator.

  • Can I actually get past that auto-config JAMF screen if I turn off Wifi? BTW, I don't actually have an account on the MBP yet. – odysseus Dec 17 '20 at 18:14
  • Is there a way to block the device enrollment requests? – odysseus Dec 18 '20 at 4:24
  • If you turn off wifi/internet, in the first setup, the remote management enrollment won't get activate. That would be one step to check. As I mentioned best way to reach your JAMF administrator. – Udhy Dec 18 '20 at 10:22
  • I posted what I consider to be a definitive answer to the post 'Why do I get a ‘Remote Management’ step when installing High Sierra?' given above. My answer works for Big Sur on the MacBook Pro M1 (2020) – odysseus Dec 18 '20 at 16:01

Not the answer you're looking for? Browse other questions tagged .