I updated to Xcode 12.3 on my MacBook Pro 2018 13" yesterday and face a strange problem right now.

Problem: Every time I open up Xcode, it will first work fine. However, after a few actions / seconds, the screen freezes and the circle loading indicator is displayed. The app does not respond anymore and I have to force close it.

More Information:

  • The freezing is Xcode specific. I can use all other Programs while Xcode is frozen and the circle is spinning. It doesn't seem like a resource problem.

  • This not only happens with existing projects. I created a new one and encountered the same Problem.

  • I alredy reinstalled Xcode, but that does not solve the problem.

  • I already deleted the ~/Library/Developer Folder (like a few other posts recommended) and installed the components on Xcode start again. Still the same problem.

Has anyone an idea on how to solve this problem?


1 Answer 1


This is a recently reported bug with Xcode 12.3. I am not aware of any response from Apple yet, but you might be able to fix this issue by turning off the over-the-air test device builds.

  • Top Menu: Window > Devices & Simulators
  • Uncheck "Connect via Network" for each physical device

I recommend filing bugs with Apple and watching the forum thread about this.

You also revert to Xcode 12.2.

  • FWIW the "Connect via Network" fix didn't work for me. I had no devices listed, and even when I connected my iPhone via cable, the option was deselected 😕
    – mluisbrown
    Commented Dec 18, 2020 at 16:41
  • Removing network connected devices and restarting seemed to fix the issue for me a while, and then after running on a USB-connected iPhone the same issue came back up, even after disconnecting from the device.
    – Ben
    Commented Jan 4, 2021 at 19:20
  • 1
    this surprisingly worked on my M1 Macbook Air Commented Mar 9, 2021 at 18:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .