1

I often take screenshots or partial screenshots on my MacBook.

For some reason, these immediately appear on my iPad - the screen turns on showing them, and they are stored on there.

This is annoying. I want it to stop.

So... Any ideas how I can prevent this happening? Thanks!

1

This is probably universal clipboard as described in Use Universal Clipboard to copy and paste between your Apple devices:

The content is automatically added to the clipboard of your other nearby device. It remains there briefly, or until you replace it by copying something else on either device.

It also mentioned in last paragraph of Take a screenshot on your Mac:

To copy a screenshot to the Clipboard, press and hold the Control key while you take the screenshot. You can then paste the screenshot somewhere else. Or use Universal Clipboard to paste it on another Apple device.

5
  • Thanks for the answer! I had guessed this too... However, handoff is not activated in either my Macbook or my iPad. However, the screenshots are still copied. Nothing else is copied, however. – Bill Mayes Dec 16 '20 at 10:25
  • Simplest way to prevent universal clipboard should be turning off Handoff on either of devices. – Aivar Paalberg Dec 16 '20 at 10:30
  • Yes. Both turned off. Still happening! – Bill Mayes Dec 16 '20 at 10:32
  • Try logging in/out of icloud on your mac and see what happens then? – AVelj Dec 16 '20 at 10:34
  • Thanks AVlej. That did it! – Bill Mayes Dec 16 '20 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .