In Catalina and earlier versions of macOS, certain keyboard shortcuts worked for dismissing alerts, but these same shortcuts no longer work for me in Big Sur.

You could and you can still cancel alert dialogs via esc and alerts with a recommended action (highlighted in blue) you can dismiss them with enter.

But you could also trigger an alert's action with, for example, ⌘ command + D, based on the title of the button (presumably).

No such keyboard shortcut I try works on the new Big Sur alerts so far. Is there a working keyboard shortcut here?

Messages delete conversation alert dialog

EDIT: Note the problem applies to Monterey as well

3 Answers 3


The new destructive action doesn't have a keyboard shortcut by default. This is likely by design:

[it] allows the system to guard a destructive-action button against accidental presses

You can enable keyboard navigation for controls (previously called Full Keyboard Access) in System Preferences → Keyboard → Shortcuts → ‘Use keyboard navigation to move focus between controls’. With this option enabled, the Cancel button is focused for activation with Space, and you can Tab to the Delete button and activate that with Space too.

  • 2
    Weird, wouldn't really consider a two key shortcut (⌘+D) to be a concern for accidental presses. Thank you for the suggestion!
    – shim
    Dec 15, 2020 at 16:50
  • 3
    @shim - really Apple, there are still people capable of making these decisions. The Cmd-key shortcut was elegant and convenient. Were there a lot of people just flailing at the keyboard out there that couldn't handle it? Isn't the Dialog Box with a warning the Destructive Action safety net? now that safety net has a safety net. So safe!
    – rebusB
    Jul 8, 2021 at 23:20
  • The action has been changed to (⌘+Delete). The whole change sounds rather silly to me, but the new keystrokes work.
    – Paul Brady
    Aug 16, 2021 at 16:56
  • ⌘+Delete doesn't do anything in Monterey, don't remember it working on Big Sur either.
    – shim
    Nov 3, 2021 at 20:13

Hit ^ + F7 fixed it for me. Now dialogs cancel button is focused automatically, and you can just press Space to pick that action, or Tab to cycle other options.

No need to enable Full Keyboard Access.

enter image description here


It's pretty lousy but a 100% keyboard method for deleting a selected conversation in Messages is:

  1. + shift + ? to open the help menu
  2. Type "De" in the search bar
  3. Use down arrow and enter to select "Delete Conversation…" in the results.
  4. Press tab then space as in @grg's answer (need to enable full keyboard access)

Tested in Monterey 12.0.1 (21A559).

Interesting, the delete and cancel buttons seem to have been swapped, at least for my locality…

delete conversation alert

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .