12

Today I have upgraded my 2020 Intel MacBook Air to Big Sur (11.1). Since upgrading, I am unable to unlock the "lock" in the System Preferences panels that require it (the window "jiggles" even with the right password) and I am unable to set up Touch ID (after entering the password it doesn't prompt me to register a new fingerprint).

I saw in other answers that others used the resetpassword utility from Recovery mode, so I did this too. The problem persisted even after changing the password. The linked answer recommends creating a new admin user, but I cannot do that as I can't unlock the "padlock" in System Preferences to do so. I also reset NVRAM to no avail.

Ultimately, I chose to reinstall Big Sur from recovery, but entering the password to unlock the disk does not "do" anything, as in, the password entry window simply fades out but the installation does not move forward and I am still able to click on the "unlock" button again.

I was wondering if anyone knew how I can solve this issue. Since the computer is relatively new, I don't mind completely resetting it.

Thank you very much.

13

Answering my own question, but... resetting the SMC (as explained here https://support.apple.com/en-ca/HT201295) ended up doing the trick for me.

1
  • 1
    Resetting SMC worked for me also. Dec 17 '20 at 9:36
6

The fix for me was actually the steps before resetting the SMC, so I didn't need to do an SMC reset. Here are those simple steps:

  1. Shut down your Mac.
  2. Press and hold the power button for 10 seconds, then release the button.
  3. Wait a few seconds, then press the power button to turn on your Mac.

Source: How to reset the SMC of your Mac by Apple

Worth noting I did first remove all existing Touch ID fingerprints from my Mac before doing this.

UPDATE: It's also worth remembering that Touch ID is disabled for the first login after a shutdown

3
  • 1
    This has been my experience, the 10 second sequence enough to re-enable fingerprint capture, unlocking the macOS and unlocking locked settings/preferences.
    – Niall
    Dec 18 '20 at 17:19
  • 2
    This worked on my 2018 MBP, and I didn't need to remove existing Touch ID fingerprints!
    – senmu
    Dec 26 '20 at 11:49
  • @senmu That's even better! Dec 27 '20 at 12:02
3

Encountered the same issue w/ System Preferences. An SMC reset fixed.

2

You can try to restore to factory settings by installing the version of macOS that came with your MacBook Air instead of Big Sur.

Here's how you do it:

  1. Turn off your Mac
  2. When you start it hold CMD+OPTION+R
  3. Connect to the internet if it ask for an internet connection
  4. When you are in internet recovery mode, open disk utility and erase the disk
  5. Exit disk utility and install a new copy of macOS
1
  • Thank you very much for your solution! Just moments before you posted it I tried resetting the SMC and it ended up doing the trick for me. It feels weird that the issue would be related with the SMC but... it worked somehow. Either way, I am appreciative of your solution and I'll keep it in mind if the problem ever comes up again. :)
    – trms
    Dec 15 '20 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .