0

I have a late 2021 unibody Mac Mini, upgraded to Catalina. For some time I have had problems where the monitor will not wake up from sleep even though the Mac is running - I think it's a known bug in the hardware/firmware.

Recently I thought I had solved this buy setting the screen to never turn off:

enter image description here

I thought it was working but recently I am coming back to my Mac after several hours and frequently I turn the monitor on with its own power button to find the same problem. Every time I have to hard reboot the thing.

How can the screen still be put to sleep when told not to? How can I prevent it?

1
  • Often monitors have their own power saving settings, have you tried changing those? – Steve Chambers Dec 14 '20 at 21:09
1

Try this:

sudo pmset -a standby 0

I think this has been helping with my 2018 MacMini (on Catalina) display wake problems. Standby is different from sleep, and not in the Settings GUI. standby 0 will make sure your Mac never goes into hibernation. (That command must be entered in the terminal, and will ask for your password. You must be using an administrator account, or one on which sudo has been enabled.)

There are also two workarounds for this that may be helpful.

  1. Always turn the monitor on first, before waking the Mac (touching keyboard or mouse).

  2. If you get the black screen, try putting the Mac to sleep and waking it again in a few seconds. You can put it in sleep by moving the mouse to the “sleep” corner set up in System Preferences, or with a key combination like Cmd-Option-Eject or Cmd-Option-Power (varies with keyboard type). Then wake it up after a few seconds by moving the mouse or pressing "Shift".

3
  • I am sure the Mac is not asleep - previously I used caffeinate but I can see the disk activity light flickering and once I plugged in a second monitor to prove it was working... just not sending output to the primary DP monitor – Mr. Boy Dec 15 '20 at 9:46
  • @Mr.Boy I think the question is not if it is asleep, but whether it had gone to sleep at some point. – Jamie Cox Dec 15 '20 at 12:45
  • I edited my answer to add some workarounds. – Jamie Cox Dec 15 '20 at 12:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .