Although there's free space on the target device, when I attempt to transfer a folder of media from my MacBook to my iPad Air 2 (circa 2014) running IOS 14.2, this fails reporting (on the MacBook) that the Airdrop was Cancelled after I accepted it and choose to save it to files.

Now I know I didn't "cancel" the transfer. And the same transfer SUCCEEDS on my iPad Pro (2018).

Why/How is this failing?

3 Answers 3


I Googled this issue and found a question on Apple's forums, but sadly with no answers.

Comparative Analysis:

I was fortunate to have uploaded the same folder successfully on an iPad Pro (2018) running IOS 14.2. This proved it was certainly possible, just not on my iPad Air 2 running the same version of IOS 14.2

So same folder containing same files, both devices running the most current version of IOS- 14.2. Airdrop succeeds on the iPad Pro (1TB storage), but reports a "cancelled" error on the sending device, a Macbook Pro (2018) running OSX 10.15.7 despite the iPad Air 2 (128 GB) having the required free space. Oh, and Bluetooth was doing nothing other than Airdrop at the time of the issue.


The Airdrop was attempted again after rebooting the iPad Air 2. I also tried disabling and re-enabling the Bluetooth on both the sending and receiving devices for the sake of completeness.

Did some testing to see if file size was a limiting factor by incrementally removing chunky files and retrying the transfer.


That was it: only after I got the folder size down to 1.5 GB, did Airdrop succeed. Then I had to airdrop the chunky files I removed to get the total folder size down to 1.5 GB and move them back into the folder on the receiving iPad Air 2. So the same volume of data was transferred in the end, proving that it wasn't down to insufficient local storage.


Since Airdrop worked with my more modern iPad Pro 2018, may only be an issue for folks using Airdrop as target devices with older legacy iPhones/iPads. Anyhoo, at least I can tell you what worked for me; YMMV. Hope this gets you out of a hole if you bump into the same problem-


I do a lot of video file manipulation for my work and use AirDrop a lot between iPhones (12 mini, XR and 6S), MacBook Pro 13” 2020, and older iPad Mini.

So I’ve had my fair share of AirDrop problems. I’ve tried everything, from shutting down and turning on devices, turning on and off the Bluetooth, and restarting the MacBook.

Usually I AirDrop from MacBook to one of the iPhones, though.

If I get a “Cancelled” (sometimes it’s “Declined”) message on my MacBook after trying to AirDrop to an iPhone, the trick that always seems to work is to delete several files from the iPhone.

Usually I already have tons of space available, like just now I had 51.1GB of 128GB of memory free on the iPhone 12 Mini, yet AirDrop from the MacBook still resulted in “Cancelled”.

But then it worked after I deleted a few videos from the iPhone.

I have no idea why this works when there is so much free memory already available, but it just does, for me.


I had the same problem for a while when sharing files between two of my macs. I've just realised that the problem I experienced had to do with Umlauts in the filenames (it's not limited to Umlauts, but it's an easy enough to understand example).

The files that I tried / failed to share were created with an application that didn't correctly write the Umlauts into the file's name. Finder was capable of showing the Umlauts correctly and most file operations work. AirDrop doesn't work though.

The easiest solution is to rename or move the file. In both cases Finder will correctly update the Umlauts and it will be able to send the files via AirDrop.

Beware: the problem may not be limited to the file's name but could also be in the directory / directories that the file's located in.

Technical detail: macOS uses Unicode normalisation https://en.wikipedia.org/wiki/Unicode_equivalence#Normalization and once Finder modified the file's name, its filename is normalised and everything works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .