1

My default app to open .md markdown files is VS Code, which unfortunately doesn't provide quick look support for markdown files: enter image description here

I've installed other apps that provide quick look for markdown files, how do I make quick look to use them without changing the default app for opening markdown files?

2 Answers 2

2

There is a way to authorize QLMarkdown. I have two Big Sur Macs: personal I bought with Catalina and upgraded to Big Sur, and my most recent work Mac purchased with Big Sur on it. The personal Mac never complained about QLMarkdown, because I had trusted it before? To get it running on the work Mac I

  • Waited until the untrusted plugin dialog came up, or force it with qlmanage -p <path-to-markdown-file>.
  • Opened System Preferences to the Security & Privacy section, General tab.
  • There was a message stating QLMarkdown was "blocked from use because it is not from an identified developer", and a button labeled Allow Anyway to trust the unsigned QLMarkdown, I clicked it.
  • Tried to QuickLook a Markdown file.
  • The dialog about running untrusted software came back up, and I was able to click a button saying I trusted it this time.
2

AFAIK, the default app for opening documents and the QuickLook generator for previewing them are two completely separate things.

If you have a QuickLook generator file for the .md format, then that will be used by the QL manager.

The Terminal command qlmanage provides a way to get the status of the QL manager, and to configure it in a limited way.

> qlmanage -m | grep "md"
  com.unknown.md -> /Users/Ben/Library/QuickLook/QLMarkdown.qlgenerator (1.3.3)

You can force which QL generator is used with

qlmanage -g /path/to/generator/
5
  • Sadly, QLMarkdown.qlgenerator is poorly code-signed, and Big-Sur refuses to use it. Is there a way to tell the OS to trust such component? Jul 7, 2021 at 8:28
  • Really? It seems to be working here, and I haven't touched it since installing Big Sur.
    – benwiggy
    Jul 7, 2021 at 8:45
  • 1
    You probably lowered your system's Gate-Keeper settings to "run any software", or you somehow "trusted" it in the past, and that trust survived the upgrade to Big-Sur Jul 15, 2021 at 12:00
  • @MottiShneor No, I haven't lowered GateKeeper. You could try deleting the quarrantine extended attribute, though; or adhoc code-signing it.
    – benwiggy
    Jul 15, 2021 at 12:43
  • ad-hoc not trusted by the OS for some reason. I wonder why such projects won't just get their certificate from Apple. I feel a $99 for a good, and valid certificate, for ALL your projects and sources, isn't THAT expensive. When I offered open-source projects to use MY certificate (officially, not as any kind of hack) they always refuse, like my Developer certificate from Apple is a disease. Jul 16, 2021 at 21:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .